Erreur #2032 [Résolu]

VBtoTRASH 59 Messages postés vendredi 18 juillet 2008Date d'inscription 31 mars 2011 Dernière intervention - 25 mars 2011 à 17:53 - Dernière réponse : VBtoTRASH 59 Messages postés vendredi 18 juillet 2008Date d'inscription 31 mars 2011 Dernière intervention
- 31 mars 2011 à 11:55
Salut,

Je bidouille avec CS4 en AS3. Avant, il était possible d'appeler en mode développement, une adresse sur le réseau. Maintenant, cela ne semble plus possible. J'ai l'erreur suivante :

Erreur d'ouverture de l'URL 'http://www.monsite.fr/eca/plume_latraverse_quel_calvaire.eca'
[IOErrorEvent type="ioError" bubbles=false cancelable=false eventPhase=2 text="Error #2032: Erreur de flux. URL: http://www.monsite.fr/eca/plume_latraverse_quel_calvaire.eca"].

Si je place l'adresse sur un navigateur, celui-ci lit le fichier .eca, qui est un fichier mp3. L'extension n'a pas de conséquences sur le résultat (eca, mp3 ou gh6 ...).

Auparavant, j'avais une erreur de sécurité (Sandbox), qu'il était facile de palier.

A vous lire
Afficher la suite 

Votre réponse

3 réponses

Meilleure réponse
nickydaquick 417 Messages postés vendredi 31 janvier 2003Date d'inscription 19 décembre 2013 Dernière intervention - 30 mars 2011 à 20:18
3
Merci
Bonjour,

1-Assure toi que le type MIME de retour (pour le fichier .eca) est
le bon , et le meme que pour les fichiers mp3.
2-Tu utilises une adresse complete et non relative:
a- dans la configuration: Use network: il faut le mettre a TRUE
b- si le site (http://monsite.fr) n'est pas le tien, il faut verifier qu'il contient a la racine un fichier crossdomain.xml pour permettre les requetes de Flash sur ce site-la

Bonne continuation.

je suis heureux de faire partie d'une grande famille ...!

Merci nickydaquick 3

Avec quelques mots c'est encore mieux Ajouter un commentaire

Codes Sources a aidé 93 internautes ce mois-ci

Commenter la réponse de nickydaquick
VBtoTRASH 59 Messages postés vendredi 18 juillet 2008Date d'inscription 31 mars 2011 Dernière intervention - 31 mars 2011 à 08:44
0
Merci
Bonjour,

Je pense que le type MIME est valide, puisque une fois en ligne, tout fonctionne parfaitement. Quant à l'adresse du site
"http://monsite.fr", il est évident que c'est le mien. J'ai le même problème avec les fichiers xml, chose que je n'avais pas auparavant.

Je n'utilise pas de fichiers crossdomain.xml puisque tout se trouve normalement sur le même espace, et dans le cas où j'exploite mes espaces sur Skydrive, il m'est impossible de placer ce fichier sous la racine. Des routines php présentes sur
mon site, s'occupent de me renvoyer le flux via proxy. Je vais regarder la configuration du 'Use Network'.

Merci pour ta réponse, qui je l'espère, résoudra ce problème.
Commenter la réponse de VBtoTRASH
VBtoTRASH 59 Messages postés vendredi 18 juillet 2008Date d'inscription 31 mars 2011 Dernière intervention - 31 mars 2011 à 11:55
0
Merci
@nickydaquick,

Re,

Je me suis souvenu que les applications flash utilisaient le cache de "Internet Exploiteur" de Micr$oft. Et comme j'avais commencé à installer IE8 sans finir le boulot, le cache de celui-ci était resté bloqué. Maintenant, tout fonctionne à nouveau.

Merci d'avoir déclenché cette étincelle de lucidité.

Pour ce qui est du fichier crossdomain.xml, j'ai pu constater qu'il n'était pas nécessaire pour les fichiers multimédias,
mais je confirme que l'utilisation de proxy php évite au sandbox de déclarer des erreurs quand on jongle avec différents
domaines.

Bonne continuation de même.

Eryc
Commenter la réponse de VBtoTRASH

Vous n'êtes pas encore membre ?

inscrivez-vous, c'est gratuit et ça prend moins d'une minute !

Les membres obtiennent plus de réponses que les utilisateurs anonymes.

Le fait d'être membre vous permet d'avoir un suivi détaillé de vos demandes et codes sources.

Le fait d'être membre vous permet d'avoir des options supplémentaires.