Pas d'erreur mais ca marche pas

Signaler
Messages postés
80
Date d'inscription
vendredi 25 janvier 2002
Statut
Membre
Dernière intervention
14 novembre 2007
-
Messages postés
3983
Date d'inscription
jeudi 14 juillet 2005
Statut
Membre
Dernière intervention
30 juin 2013
-
Bonjour!

J'ai une base de données Mysql et un intranet que je developpe sous asp . Lors d'un update je n'ai aucun message d'erreur mais ... je n'ai rien qui se passe dans ma base de donnée alors que je suis sur que la requete est prise en compte.
Ma requete:

set Command1 = Server.CreateObject("ADODB.Command")
Command1.ActiveConnection = MM_base_STRING
Command1.CommandText = "UPDATE EXAM SET MaAnt='"&MaAnt&"',Mois='"&Mois&"',Annee='"&Annee&"',[...]WHERE Id_Exam='"&id&"'"
Command1.CommandType = 1
Command1.CommandTimeout = 0
Command1.Prepared = true
Command1.Execute()

Est ce que qq'un a une idée de pourquoi ca marche pas ?

Merci




MÔA Gloppy

3 réponses

Messages postés
489
Date d'inscription
mardi 16 novembre 2004
Statut
Membre
Dernière intervention
22 novembre 2007

Peut être que MySQL n'execute pas de requete sans ; à la fin
Messages postés
80
Date d'inscription
vendredi 25 janvier 2002
Statut
Membre
Dernière intervention
14 novembre 2007

Merci de te pencher sur le pb mais ... non ca marche pas plus!! Entre temps j'ai essayé de modifier le commandtype et c'est pareil ca marche pas...
D'autres ID?????

MÔA Gloppy
Messages postés
3983
Date d'inscription
jeudi 14 juillet 2005
Statut
Membre
Dernière intervention
30 juin 2013
13
exécute directement via :
Connection.Execute("UPDATE EXAM SET MaAnt='"&MaAnt&"',Mois='"&Mois&"',Annee='"&Annee&"',[...]WHERE Id_Exam='"&id&"'")