Acces au repertoire refusé

matlocker 178 Messages postés jeudi 21 février 2002Date d'inscription 30 juillet 2008 Dernière intervention - 1 juin 2005 à 19:24 - Dernière réponse : tbbuim1 940 Messages postés jeudi 20 février 2003Date d'inscription 3 février 2011 Dernière intervention
- 11 nov. 2005 à 10:16
Bonjour,

J'ai un petit soucis. J'ai un code tout bete qui ecris un fichier texte ds le repertoire de mon site. Mais il m'indique je ne possede pas les droits : "L'accès au chemin d'accès ....est refusé".

Alors que j'ai mis les droit d'ecriture sur mon repertoire ds iis.

Quelq'un aurais une explication ?

Voila mon code :


Dim t
As
New StreamWriter(Server.MapPath("t.txt"))


t.WriteLine("hhhhhhhhh")


t.Close()
Afficher la suite 

Votre réponse

13 réponses

cs_Nurgle 1648 Messages postés samedi 6 novembre 2004Date d'inscription 28 avril 2011 Dernière intervention - 1 juin 2005 à 20:50
0
Merci
Salut



Tu dois donner l'autorisation windows (dans Windows et pas dans IIS ) à l'utilisateur du PC nommée ASPNET !!



(si tu es sous Win2003 c'est IUSR_TONSERVEUR qu'il faut autoriser...)



Donc dans l'explorateut : clique droit sur le dossier --> propriétés
--> et tu autorises ASPNET en lecture/écriture/modification/...etc



@+++




Nurgle
C'est une grande folie que de vouloir être sage tout seul !
Commenter la réponse de cs_Nurgle
matlocker 178 Messages postés jeudi 21 février 2002Date d'inscription 30 juillet 2008 Dernière intervention - 1 juin 2005 à 23:40
0
Merci
Salut Nurgle,

Je suis sous windows xp et qd je clique sur un repertoire j'ai pas de menu pour autoriser aspnet en lecture ecriture. J'ai manqué quelque chose ?
Commenter la réponse de matlocker
Mickey VB 50 Messages postés jeudi 5 août 2004Date d'inscription 15 janvier 2007 Dernière intervention - 2 juin 2005 à 10:10
0
Merci
dans l'explorateur tu vas dans le répertoire C:\Inetpub\wwwroot\ => click droit sur ton répertoire puis propriété => onglet sécurité. Vérifie que IUSR_NOM DE TON SERVEUR et IWAM_NOM DE TON SERVEUR sont bien en lecture et ecriture puis tu rajoutes ASP.NET et tu lui donnes les droits en lecture et ecriture (pour l'emplacement tu sélectionnes le nom de ton serveur si c'est ton pc = nom du pc)

ça fonctionne très bien sous windows xp

Mickey
[mailto:mcordeiro@fr.ebsco.com mcordeiro@fr.ebsco.com]
Commenter la réponse de Mickey VB
matlocker 178 Messages postés jeudi 21 février 2002Date d'inscription 30 juillet 2008 Dernière intervention - 3 juin 2005 à 14:28
0
Merci
Mais je vous assure j'ai pas onglet securite......comment est ce possible ?
Commenter la réponse de matlocker
Mickey VB 50 Messages postés jeudi 5 août 2004Date d'inscription 15 janvier 2007 Dernière intervention - 3 juin 2005 à 14:49
0
Merci
tu n'es pas administrateur de ton poste?

Mickey
[mailto:mcordeiro@fr.ebsco.com mcordeiro@fr.ebsco.com]
Commenter la réponse de Mickey VB
matlocker 178 Messages postés jeudi 21 février 2002Date d'inscription 30 juillet 2008 Dernière intervention - 3 juin 2005 à 14:58
0
Merci
Non je viens de me rendre compte que j'avais activé l'option "utiliser le partage de fichier simple" donc j'avais pas onglet securite.

Merci ca devrais etre bon maintenant.

Cependant je comprends pas un truc. Quand on specifie des droit de lecture/ecriture dans IIS sur un repertoire ca sert a quoi ?
Commenter la réponse de matlocker
cs_Nurgle 1648 Messages postés samedi 6 novembre 2004Date d'inscription 28 avril 2011 Dernière intervention - 3 juin 2005 à 18:58
0
Merci
ça spécifie les droits de l'application web sur le dossier choisit.

Mais tout ça s'éxécute dans le processus de IIS et celui-ci est lancé
par IUSR_TONSERVEUR. Et le code asp.net est transmis par IIS au
Framework qui lui s'exécute dans l'utilisateur ASPNET. Donc il faut que
tout ce petit monde là ai l'accès en écriture au fichier concerné.



(j'espère que c'est compréhensible...)


Nurgle
C'est une grande folie que de vouloir être sage tout seul !
Commenter la réponse de cs_Nurgle
matlocker 178 Messages postés jeudi 21 février 2002Date d'inscription 30 juillet 2008 Dernière intervention - 6 juin 2005 à 16:45
0
Merci
Honnetement j'ai pas bien compris mias je vais me renseigner.

Merci.
Commenter la réponse de matlocker
cs_Nurgle 1648 Messages postés samedi 6 novembre 2004Date d'inscription 28 avril 2011 Dernière intervention - 6 juin 2005 à 17:00
0
Merci
Je vais essayer d'expliquer :



le framework .net accède à Windows sous le nom d'utilisateur ASPNET. Si
tu écris dans un dossier en .net, il faut que Windows l'autorise, donc
il faut que ASPNET en ai le droit.



IIS lui, accède à Windows sous deux noms d'utilisateurs :
IUSR_TONSERVEUR et IWAM_TONSERVEUR. Ils ont des usages différents mais
ce qui compte c'est que si une application qui utilise IIS sous la
forme d' ISAPI (donc ASP, PHP, CGI...tout sauf le .net ) veut écrire quelque part il faut que :

- IIS donne le droit à ton application de le faire (donc ça c'est les droits que tu modifies dans IIS).

- Windows donne le droit à IIS d'écrire dans le dossier (et là c'est IUSR_TONSERVEUR qui doit avoir les droits d'écriture)



Donc en asp.net, il faut juste autoriser (dans Windows) ASPNET à écrire dans le dossier (normalement...).

Alors que dans les autres languages plus anciens, c'est IUSR_TONSERVEUR
qui doit avoir les droits d'écriture ; et ton application web doit
avoir l'autorisation de IIS.



(c'est mieux là non )




Nurgle
C'est une grande folie que de vouloir être sage tout seul !
Commenter la réponse de cs_Nurgle
matlocker 178 Messages postés jeudi 21 février 2002Date d'inscription 30 juillet 2008 Dernière intervention - 22 juin 2005 à 00:00
0
Merci
Merci Nurgle pour avoir passé du temps pour ta reponse. Et la j'ai "tout bien compris" .
Commenter la réponse de matlocker
matlocker 178 Messages postés jeudi 21 février 2002Date d'inscription 30 juillet 2008 Dernière intervention - 22 juin 2005 à 00:00
0
Merci
Merci Nurgle pour avoir passé du temps pour ta reponse. Et la j'ai "tout bien compris" .
Commenter la réponse de matlocker
tbbuim1 940 Messages postés jeudi 20 février 2003Date d'inscription 3 février 2011 Dernière intervention - 11 nov. 2005 à 10:03
0
Merci
Moi j'ai bien compris, mais je n'ai pas d'utilisateur IUSR_MONSERVEUR!


Même si je mets control total à tout le monde ça marche pas!

je suis sous 2003 II6

TBBUIM
Commenter la réponse de tbbuim1
tbbuim1 940 Messages postés jeudi 20 février 2003Date d'inscription 3 février 2011 Dernière intervention - 11 nov. 2005 à 10:16
0
Merci
J'ai trouvé, je leur ai donnée accès à tous les rep de intepub et inetpub
mais ça ne marche toujours pas!
TBBUIM
Commenter la réponse de tbbuim1

Vous n'êtes pas encore membre ?

inscrivez-vous, c'est gratuit et ça prend moins d'une minute !

Les membres obtiennent plus de réponses que les utilisateurs anonymes.

Le fait d'être membre vous permet d'avoir un suivi détaillé de vos demandes et codes sources.

Le fait d'être membre vous permet d'avoir des options supplémentaires.