Erreur d'accès au chemin du dossier [Résolu]

Signaler
Messages postés
230
Date d'inscription
dimanche 8 février 2009
Statut
Membre
Dernière intervention
12 octobre 2011
-
Messages postés
14673
Date d'inscription
vendredi 14 mars 2003
Statut
Modérateur
Dernière intervention
28 juin 2020
-
Bonjour à tous, J'ai un gros problème. Lorsque j'ouvre mon application, j'ai l'erreur suivante :
"L'accès au chemin d'accès : C:\Users\Olivier\Documents\Visual Basic 2008\Projects\WindowsApplication1\Bin\Debug est refusé"
Même si je l'ouvre en Administrateur. Voici la partie de mon code qui bugge :

FileOpen(1, Application.StartupPath, OpenMode.Binary, OpenAccess.Read, OpenShare.Shared)


Merci d'avance à tous ceux qui m'aideront.

10 réponses

Messages postés
14673
Date d'inscription
vendredi 14 mars 2003
Statut
Modérateur
Dernière intervention
28 juin 2020
143
Bonjour,

Préfère accéder au fichier par les flux :
IO.StreamReader
IO.StreamWriter
IO.File.Open

Mon site
Messages postés
230
Date d'inscription
dimanche 8 février 2009
Statut
Membre
Dernière intervention
12 octobre 2011

Merci je vais essayer
Messages postés
230
Date d'inscription
dimanche 8 février 2009
Statut
Membre
Dernière intervention
12 octobre 2011

ca ne marche pas
Messages postés
14673
Date d'inscription
vendredi 14 mars 2003
Statut
Modérateur
Dernière intervention
28 juin 2020
143
Bonjour,

Dans ton code :
FileOpen(1, Application.StartupPath, OpenMode.Binary, OpenAccess.Read, OpenShare.Shared)

Le fichier ciblé semble être Application.StartupPath, mais ce n'est pas un fichier, mais un dossier ...

Mon site
Messages postés
230
Date d'inscription
dimanche 8 février 2009
Statut
Membre
Dernière intervention
12 octobre 2011

Oui je sais je m'étais trompé je voulais dire :

FileOpen(1, Application.ExecutablePath, OpenMode.Binary, OpenAccess.Read, OpenShare.Shared)
Messages postés
14673
Date d'inscription
vendredi 14 mars 2003
Statut
Modérateur
Dernière intervention
28 juin 2020
143
Bonjour,

C'est normal, je pense, car le programme est en cours d'exécution, donc ouvert, ça peut poser le problème que tu as constaté.

Mon site
Messages postés
230
Date d'inscription
dimanche 8 février 2009
Statut
Membre
Dernière intervention
12 octobre 2011

C'est bon merci j'ai résolu le problème
Messages postés
14673
Date d'inscription
vendredi 14 mars 2003
Statut
Modérateur
Dernière intervention
28 juin 2020
143
Bonjour,

Si tu as changé quelque chose, ça peut être intéressant pour les autres utilisateurs de connaitre comment tu y es arrivé.

Mon site
Messages postés
230
Date d'inscription
dimanche 8 février 2009
Statut
Membre
Dernière intervention
12 octobre 2011

J'ai simplement lancé le programme en tant qu'Admin
Messages postés
14673
Date d'inscription
vendredi 14 mars 2003
Statut
Modérateur
Dernière intervention
28 juin 2020
143
D'accord, merci quand même de le signaler :)