Violation d'adresse ......... dans le module

Résolu
maigeri
Messages postés
5
Date d'inscription
jeudi 21 avril 2011
Statut
Membre
Dernière intervention
11 mai 2011
- 9 mai 2011 à 16:50
maigeri
Messages postés
5
Date d'inscription
jeudi 21 avril 2011
Statut
Membre
Dernière intervention
11 mai 2011
- 11 mai 2011 à 18:52
Salut à tous,
Je suis actuellement en train de développer une application de gestion de parc informatique sous Delhpi.

Cette apply a très bien marché depuis la semaine dernière, mais aujourd'hui un problème est survenu, à savoir que tous les jours, l'apply met à jour sa base. Aujourd'hui arrivé au 75ième PC du réseau la mis à jour c'est arreté avec comme message d'erreur :
" Violation d'accès à l'adresse xxxxxxxxxx dans le module 'Project.exe'.Lecture de l'adresse 000000000."


Je ne comprend pas pourquoi ce message n'arrive qu'au 75ième Pc et pourquoi il s'affiche.



Merci de votre réponse.

6 réponses

maigeri
Messages postés
5
Date d'inscription
jeudi 21 avril 2011
Statut
Membre
Dernière intervention
11 mai 2011

10 mai 2011 à 15:29
Merci à toi c'était le spouler d'impression de ce Pc qui faisait planter l'application
3
cs_bonanux
Messages postés
11
Date d'inscription
lundi 21 avril 2003
Statut
Membre
Dernière intervention
19 février 2012

10 mai 2011 à 13:37
Bonjour,

Ben moi non plus, je ne comprends pas ;-)

Mets toi en débugage pas à pas et essaies d'identifier le code qui te génère l'erreur... ca sera plus simple pour tous le monde !
C'est probablement une variable non affectée ou un truc du genre ... Combien de pc doit il y avoir sur ton réseau ? Y en aurait-il pas un qui apparait en netbios et qui n'existe plus vraiment ? test tu bien l'existence de l'hôte ? Quel traitement fais tu sur détection de l'hôte ?


bonanux
0
maigeri
Messages postés
5
Date d'inscription
jeudi 21 avril 2011
Statut
Membre
Dernière intervention
11 mai 2011

10 mai 2011 à 14:01
Il y a 175 machines à tester.
J'ai fais le pas à pas il plante sur une condition toute simple (Pos(.....)<>0).
Donc je comprend pas vraiment ^^.
De plus on arrive a pinger cette machine donc il n'y a pas de problèmes de ce côté la.
0
cs_bonanux
Messages postés
11
Date d'inscription
lundi 21 avril 2003
Statut
Membre
Dernière intervention
19 février 2012

10 mai 2011 à 16:27
Ok, content que tu aies résolu ton problème !


bonanux
0

Vous n’avez pas trouvé la réponse que vous recherchez ?

Posez votre question
Utilisateur anonyme
11 mai 2011 à 16:07
Salut

Tu devrais profiter de ce petit message d'erreur, pour rajouter un Try .... Except/Finally dans la procedure/fonction correspondante ça t'évitera que ce message réapparaisse en cas de beug de l'imprimante.

Enfin je dis cela, je dis rien
0
maigeri
Messages postés
5
Date d'inscription
jeudi 21 avril 2011
Statut
Membre
Dernière intervention
11 mai 2011

11 mai 2011 à 18:52
C'est la premiere chose que j'ai faite

Mais merci quand même
0