Violation d'adresse ......... dans le module [Résolu]

maigeri 5 Messages postés jeudi 21 avril 2011Date d'inscription 11 mai 2011 Dernière intervention - 9 mai 2011 à 16:50 - Dernière réponse : maigeri 5 Messages postés jeudi 21 avril 2011Date d'inscription 11 mai 2011 Dernière intervention
- 11 mai 2011 à 18:52
Salut à tous,
Je suis actuellement en train de développer une application de gestion de parc informatique sous Delhpi.

Cette apply a très bien marché depuis la semaine dernière, mais aujourd'hui un problème est survenu, à savoir que tous les jours, l'apply met à jour sa base. Aujourd'hui arrivé au 75ième PC du réseau la mis à jour c'est arreté avec comme message d'erreur :
" Violation d'accès à l'adresse xxxxxxxxxx dans le module 'Project.exe'.Lecture de l'adresse 000000000."


Je ne comprend pas pourquoi ce message n'arrive qu'au 75ième Pc et pourquoi il s'affiche.



Merci de votre réponse.
Afficher la suite 

Votre réponse

6 réponses

Meilleure réponse
maigeri 5 Messages postés jeudi 21 avril 2011Date d'inscription 11 mai 2011 Dernière intervention - 10 mai 2011 à 15:29
3
Merci
Merci à toi c'était le spouler d'impression de ce Pc qui faisait planter l'application

Merci maigeri 3

Avec quelques mots c'est encore mieux Ajouter un commentaire

Codes Sources a aidé 102 internautes ce mois-ci

Commenter la réponse de maigeri
cs_bonanux 11 Messages postés lundi 21 avril 2003Date d'inscription 19 février 2012 Dernière intervention - 10 mai 2011 à 13:37
0
Merci
Bonjour,

Ben moi non plus, je ne comprends pas ;-)

Mets toi en débugage pas à pas et essaies d'identifier le code qui te génère l'erreur... ca sera plus simple pour tous le monde !
C'est probablement une variable non affectée ou un truc du genre ... Combien de pc doit il y avoir sur ton réseau ? Y en aurait-il pas un qui apparait en netbios et qui n'existe plus vraiment ? test tu bien l'existence de l'hôte ? Quel traitement fais tu sur détection de l'hôte ?


bonanux
Commenter la réponse de cs_bonanux
maigeri 5 Messages postés jeudi 21 avril 2011Date d'inscription 11 mai 2011 Dernière intervention - 10 mai 2011 à 14:01
0
Merci
Il y a 175 machines à tester.
J'ai fais le pas à pas il plante sur une condition toute simple (Pos(.....)<>0).
Donc je comprend pas vraiment ^^.
De plus on arrive a pinger cette machine donc il n'y a pas de problèmes de ce côté la.
Commenter la réponse de maigeri
cs_bonanux 11 Messages postés lundi 21 avril 2003Date d'inscription 19 février 2012 Dernière intervention - 10 mai 2011 à 16:27
0
Merci
Ok, content que tu aies résolu ton problème !


bonanux
Commenter la réponse de cs_bonanux
Utilisateur anonyme - 11 mai 2011 à 16:07
0
Merci
Salut

Tu devrais profiter de ce petit message d'erreur, pour rajouter un Try .... Except/Finally dans la procedure/fonction correspondante ça t'évitera que ce message réapparaisse en cas de beug de l'imprimante.

Enfin je dis cela, je dis rien
Commenter la réponse de Utilisateur anonyme
maigeri 5 Messages postés jeudi 21 avril 2011Date d'inscription 11 mai 2011 Dernière intervention - 11 mai 2011 à 18:52
0
Merci
C'est la premiere chose que j'ai faite

Mais merci quand même
Commenter la réponse de maigeri

Vous n'êtes pas encore membre ?

inscrivez-vous, c'est gratuit et ça prend moins d'une minute !

Les membres obtiennent plus de réponses que les utilisateurs anonymes.

Le fait d'être membre vous permet d'avoir un suivi détaillé de vos demandes et codes sources.

Le fait d'être membre vous permet d'avoir des options supplémentaires.