Econio.h petit bug

Signaler
Messages postés
50
Date d'inscription
samedi 20 avril 2002
Statut
Membre
Dernière intervention
11 mars 2010
-
Messages postés
4
Date d'inscription
mercredi 24 juillet 2002
Statut
Membre
Dernière intervention
24 juillet 2002
-
Bonjour,

J'ai intallé econio.h (mais pas econio.ccp), je fais le petit test que voilà:

#include <econio.h>
#include

int main()
{
textcolor(YELLOW);
cout<<"allo";
return 0;
}

Pas d'erreur lors de la compilation mais quand je veux exécuter voici les messages:

Linking...
main.obj : error LNK2001: unresolved external symbol _textcolor
Debug/test.exe : fatal error LNK1120: 1 unresolved externals
Error executing link.exe.

J'ai donc ajouté les codes de "econio.ccp" dans le même fichier (à la suite de econio.h). Ça fonctionne sauf que mon texte est toujours en noir sur fond blanc????

Merci d'avance

Cognac

4 réponses

Messages postés
269
Date d'inscription
mercredi 24 avril 2002
Statut
Membre
Dernière intervention
9 juin 2003

essaye d'ajouter stdlib et stdio
ptet quye conio depend aussi de ces deux libs
***raph***
Messages postés
50
Date d'inscription
samedi 20 avril 2002
Statut
Membre
Dernière intervention
11 mars 2010

Non, j'ai ajouté ces deux lib. dans mon test et dans econio.h sans succès. Je suis certain que ce n'est pas grand chose car je n'obtient aucun message d'erreur. J'ai aussi fais un test sur gotoxy, ça fonctionne mais uniquement pour le premier si j'ajoute un deuxième ça ne fonctionne plus.
Messages postés
126
Date d'inscription
mercredi 18 juillet 2001
Statut
Membre
Dernière intervention
27 octobre 2004

Dans les fichiers du projet, rajoute le fichier econio.cpp.
Cela devrait alors fonctionner.

Cordialement.
Messages postés
4
Date d'inscription
mercredi 24 juillet 2002
Statut
Membre
Dernière intervention
24 juillet 2002

sur la barre des menus tu fais projet\settings, tu sélextionne l'onglet link, et dans object/library modules, tu rajoute econio.lib (si tu l'as)
nigloudouille