Problème de Loadmovie

HDW900 Messages postés 5 Date d'inscription jeudi 7 juillet 2005 Statut Membre Dernière intervention 8 juillet 2005 - 7 juil. 2005 à 15:13
Neneuf Messages postés 4 Date d'inscription mardi 14 juin 2005 Statut Membre Dernière intervention 7 juillet 2005 - 7 juil. 2005 à 16:35
Bonjour,

Je découvre ce site, étant débutant en Flash MX, je pense que c'est une mine d'infos.

J'ai un petit problème avec Loadmovie.

J'ai crée un site qui marche bien mais j'ai fais la fatale erreur de mettre tous mes calques sur le même fichier. Donc lorsque je balance sur internet, personne à part moi n'arrive à ouvrir mon site. (trop lourd)

Donc on m'a dit qu'il fallait que je partitionne mes calques sur différents fichiers flash et qu'en suite, mes boutons devaient les appeler grace à la fonction loadmovie

C'est là que viens le problème, avant de me lancer, j'ai recrée une page flash toute vierge pour me faire la main et je suis incapable d'appeler un autre fichier swf avec la fonction loadmovie. J'ai créé un bouton sur le premier fichier qui s'appelle: départ
Ce bouton est sur la premiere frame
J'ai créé un oval rouge sur un autre fichier nommé test que j'ai exporté en swf et qui s'appelle: arrivée
J'ai donc donné l'ordre au bouton qui se trouve dans le fichier départ :
(on press) (loadmovie("arrivée.swf", test))

Et quand je teste l'animation et que je clique sur le bouton, rien ne se passe.

Je voudrais juste savoir comment appeler grace à un bouton un fichier swf. j'ai passé des heures dessus en testant différents codes, parfois il n'y a même aucune erreur dans le script et ca ne marche pas quand meme.

Au secours !!!!!

Merci d'avance

3 réponses

Neneuf Messages postés 4 Date d'inscription mardi 14 juin 2005 Statut Membre Dernière intervention 7 juillet 2005
7 juil. 2005 à 16:32
bon s alut ton problème est très simple, tout dabord tu ne doit pas mettre d'accent sur le nom de tes fichirer c une règle d'or.
ensuite pour appeler un swf avec un bouton tu créé un clip vide que tu peu appeler zone, que tu intègrara dans ta scène c'est lui que resevra le swf, une fois intégré tu lui donne un nom d'occurence ( zone ), ensuite sur ton bouton tu met comme action,
on (press) {
loadMovie ("arrivee.swf", zone);
}

Voila je peu pas faire mieu pour t'expliquer. Bonne chance.
0
Neneuf Messages postés 4 Date d'inscription mardi 14 juin 2005 Statut Membre Dernière intervention 7 juillet 2005
7 juil. 2005 à 16:32
bon s alut ton problème est très simple, tout dabord tu ne doit pas mettre d'accent sur le nom de tes fichirer c une règle d'or.
ensuite pour appeler un swf avec un bouton tu créé un clip vide que tu peu appeler zone, que tu intègrara dans ta scène c'est lui que resevra le swf, une fois intégré tu lui donne un nom d'occurence ( zone ), ensuite sur ton bouton tu met comme action,
on (press) {
loadMovie ("arrivee.swf", zone);
}

Voila je peu pas faire mieu pour t'expliquer. Bonne chance.
0
Neneuf Messages postés 4 Date d'inscription mardi 14 juin 2005 Statut Membre Dernière intervention 7 juillet 2005
7 juil. 2005 à 16:35
bon s alut ton problème est très simple, tout dabord tu ne doit pas mettre d'accent sur le nom de tes fichirer c une règle d'or.
ensuite pour appeler un swf avec un bouton tu créé un clip vide que tu peu appeler zone, que tu intègrara dans ta scène c'est lui que resevra le swf, une fois intégré tu lui donne un nom d'occurence ( zone ), ensuite sur ton bouton tu met comme action,
on (press) {
loadMovie ("arrivee.swf", zone);
}

Voila je peu pas faire mieu pour t'expliquer. Bonne chance.
0