PROBLEME SOUS WINDOWS 2000

Résolu
Signaler
Messages postés
9
Date d'inscription
mardi 21 décembre 2004
Statut
Membre
Dernière intervention
25 janvier 2005
-
Messages postés
9
Date d'inscription
mardi 21 décembre 2004
Statut
Membre
Dernière intervention
25 janvier 2005
-
Bonjour à tous,
Aprés avoir empaqueté et créé un setup avec "Install creator" mon programme tourne au top sur windows XP. Mais lorsque j'ai voulu le faire tourner sous windows 2000 il m'affiche le message suivant:
"La classe n'est pas enregistrée. Recherche d'un objet avec CLSID:
{00000010-0000-0010-8000-00aa006d2ea4}"

Si quelqu'un avait une petite idée...
Merci.

2 réponses

Messages postés
4172
Date d'inscription
mercredi 30 juillet 2003
Statut
Membre
Dernière intervention
9 juin 2006
27
va sur ton poste XP, ouvre regedit et recherche la chaine "{00000010-0000-0010-8000-00aa006d2ea4}", tu saura alors quel DLL ou OCX n'a pas été copié sur ton Win2k. Reste à le reprendre depuis le XP, le remettre au bon endroit et faire un regsvr32 dessus pour l'enregistrer sur le Win2k. Et cela devrait fonctionner !!
C'est ton setup qui n'a pas bien fait son boulot !! Pour corriger ton setup, je te conseille plutot d'utiliser InnoSetup et son pote IStools !! Je n'ai jamais réussi à le mettre en défaut eclui-la !!


Christophe R
3
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

Codes Sources 109 internautes nous ont dit merci ce mois-ci

Messages postés
9
Date d'inscription
mardi 21 décembre 2004
Statut
Membre
Dernière intervention
25 janvier 2005

Merci pour ton aide, je vais de ce pas me procurer InnoSetup / IStools et recommencer la mannip !
A +
3
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

Codes Sources 109 internautes nous ont dit merci ce mois-ci