Fonction mail()

Signaler
Messages postés
10
Date d'inscription
samedi 24 février 2007
Statut
Membre
Dernière intervention
1 avril 2013
-
Messages postés
12
Date d'inscription
dimanche 8 avril 2007
Statut
Membre
Dernière intervention
20 septembre 2013
-
Bonjour tout le monde

S'il vous plait c quoi la solution a ce probleme,verifier smtp mais comment ??
Warning: mail(): Failed to connect to mailserver at "localhost" port 25, verify your "SMTP" and "smtp_port" setting in php.ini or use ini_set() in c:\program files\easyphp1-8\www\gestion\envoyer_email.php on line 94

voila je ai ouvert php.ini et jai trouve :

[mail function]
; For Win32 only.
; http://php.net/smtp
SMTP = localhost
; http://php.net/smtp-port
smtp_port = 25

; For Win32 only.
; http://php.net/sendmail-from
sendmail_from = you@yourdomain

jai essaié de modifier les parametre comme suivant :
SMTP = smtp.gmail.com
smtp_port = 465
mais tt jours meme résultat

jai utilise :

win 7
WampServer2.1e-x32
Version de MySQL:5.5.8
Version de PHP:5.3.5
Version de Apache:2.2.17
jai travaile en local
Qui peut m'aide svp
merci en avance

6 réponses

Messages postés
224
Date d'inscription
vendredi 26 novembre 2010
Statut
Membre
Dernière intervention
11 juin 2013
7
Bonjour,

le problème vient du fait que ta fonction mail cherche un serveur SMTP sur ta machine (localhost). Il faut donc configurer un smtp externe (gmail, hotmail, ...) pour envoyer des messages.
Messages postés
10
Date d'inscription
samedi 24 février 2007
Statut
Membre
Dernière intervention
1 avril 2013

Bonjour,

voici mon fonction mail():

$de_nom = "nomste"; //Nom de l'envoyeur
$de_mail = "email@yahoo.fr"; //Email de l'envoyeur
$vers_mail ="email@yahoo.fr"; //Email du receveur
$sujet = "Mot de passe"; //Sujet du mail
$message="mot de passe";
$entete = "MIME-Version: 1.0\r\n";
$entete .= "Content-type: text/html; charset=iso-8859-1\r\n";
$entete .= "To: $vers_mail <$vers_mail>\r\n";
$entete .= "From: $de_nom <$de_mail>\r\n";
if(!mail($vers_mail, $sujet, $message, $entete)){
echo "L'email n'a pu être envoyé à $vers_mail
";
echo $message;
}
svp comment configurer mon serveur smtp
je besoin de vous d'aide
Messages postés
224
Date d'inscription
vendredi 26 novembre 2010
Statut
Membre
Dernière intervention
11 juin 2013
7
Bonjour,

Tu peux personnaliser ce bout de code:
ini_set("SMTP", $smtpyahoo);
ini_set("smtp_port", $port);
ini_set("smtp_user", $username);
ini_set("smtp_pass", $password);
ou alors modifier le fichier php.ini avec les bonnes valeurs pour SMTP, smtp_port, smtp_user, smtp_pass.
Pour info tu peux trouver la configuration ici pour yahoo.
Messages postés
10
Date d'inscription
samedi 24 février 2007
Statut
Membre
Dernière intervention
1 avril 2013

bonjour ,
merci pour voute réponse

oui je configure mon serveur smtp

comme suivant :


[mail function]
; For Win32 only.
; http://php.net/smtp
SMTP = smtp.gmail.com
; http://php.net/smtp-port
smtp_port = 25

; For Win32 only.
; http://php.net/sendmail-from
sendmail_from = moi@gmail.com


et je modifier le code de fonction mail() :

$de_nom = "nomste"; //Nom de l'envoyeur
$de_mail = "emai@gmail.com"; //Email de l'envoyeur
$vers_mail ="email@gmail.com"; //Email du receveur
$sujet = "Mot de passe"; //Sujet du mail
$message="mot de passe";
$entete = "MIME-Version: 1.0\r\n";
$entete .= "Content-type: text/html; charset=iso-8859-1\r\n";
$entete .= "To: $vers_mail <$vers_mail>\r\n";
$entete .= "From: $de_nom <$de_mail>\r\n";
if(!mail($vers_mail, $sujet, $message, $entete)){
echo "L'email n'a pu être envoyé à $vers_mail
";
echo $message;
}
mais j'ai un msg d’erreur suivante:

Warning: mail() [function.mail]: SMTP server response: 530 5.7.0 Must issue a STARTTLS command first. df4sm39277248wib.4 in C:\wamp\www\siteImemmezri\modificationlogin.php on line 81

SVP d'ou vient cette erreure
svp encour un peut d'aide
Messages postés
224
Date d'inscription
vendredi 26 novembre 2010
Statut
Membre
Dernière intervention
11 juin 2013
7
Salut,

Met ceci:
ini_set("SMTP","ssl://smtp.gmail.com");
ini_set("smtp_port","465");

ou dans le php.ini
[mail function]
; For Win32 only.
; http://php.net/smtp
SMTP = ssl://smtp.gmail.com
; http://php.net/smtp-port
smtp_port = 465
Messages postés
10
Date d'inscription
samedi 24 février 2007
Statut
Membre
Dernière intervention
1 avril 2013

Bonjour;

j'ai modifier le fichier php.ini

comme vous indiquez

mais il m'affiche le msg d'erreur suivante

Warning: mail() [function.mail]: Failed to connect to mailserver at "smtp.gmail.com" port 465, verify your "SMTP" and "smtp_port" setting in php.ini or use ini_set() in C:\wamp\www\monsite\mail.php on line 82

SVP
qui peut m'aide
Messages postés
12
Date d'inscription
dimanche 8 avril 2007
Statut
Membre
Dernière intervention
20 septembre 2013

bonjour
jai le meme erreur.comment resoudre ce probleme ?
mercid'avance