Message d'erreur sur phpMyAdmin [Résolu]

cs_inaden 619 Messages postés mercredi 4 avril 2007Date d'inscription 27 août 2010 Dernière intervention - 4 avril 2009 à 13:14 - Dernière réponse : cs_inaden 619 Messages postés mercredi 4 avril 2007Date d'inscription 27 août 2010 Dernière intervention
- 5 avril 2009 à 12:16
Bonjour,
après maintes pérégrination, j'ai enfin accès à phpMyAdmin.
Il ya deux messages d'erreur en bas de page :

• PHP ne peut charger l'extension mcrypt, veuillez vérifier votre configuration de PHP
et
• Vous devez ajouter dans le fichier de configuration une phrase de passe secrète (blowfish_secret).

Quelqu'un sait-il comment lever ces problème et si cela a de facheuse conséquence sur l'utilisation de phpMyAdmin.
Merci d'avance pour vos suggestions.

Tout vient à qui sait attendre
Afficher la suite 

Votre réponse

18 réponses

Meilleure réponse
kohntark 3708 Messages postés lundi 5 juillet 2004Date d'inscription 27 avril 2012 Dernière intervention - 5 avril 2009 à 12:13
3
Merci
Il y a ça dans la doc :
"When using the "cookie"
authentication method, the
<tt>mcrypt</tt> extension
is strongly suggested for most users and is required for
64–bit machines. Not using mcrypt will cause phpMyAdmin to
load pages significantly slower.
"
=>
Lorsque la méthode d'authentification par cookie est utilisée, l'extension mcrypt est recommandée pour la majorité des utilisateurs, et est indispensable pour les machines en 64 bits. Ne pas utiliser mcrypt rend phpMyAdmin beaucoup plus lent lors du chargement des pages.

Pour info cette alerte peut être desactivée.

...crée donc un nouveau sujet, et commence à utiliser mysql

Kohntark -

Merci kohntark 3

Avec quelques mots c'est encore mieux Ajouter un commentaire

Codes Sources a aidé 93 internautes ce mois-ci

Commenter la réponse de kohntark
cs_inaden 619 Messages postés mercredi 4 avril 2007Date d'inscription 27 août 2010 Dernière intervention - 4 avril 2009 à 13:38
0
Merci
Question complémentaire :
je n'ai réussi à me connecter que comme localhost sans mot de passe.
Sur la page d'accueil j'ai :
MySQL localhost
<li id="li_create_database"><!-- db creation no privileges message -->Créer une base de données:
aucun privilège</li>Et donc pas d'accès pour créer une base de données.
Comment faire ??? Est-ce lié à ma question au dessus ? Est-ce parce que je suis en "localhost" ?

PS. Je dois m'absenter, mais n'hésiter pas, je reprendrais la discussion dès que possible (ce soir ou demain)
Merci d'avance.

Tout vient à qui sait attendre
Commenter la réponse de cs_inaden
kohntark 3708 Messages postés lundi 5 juillet 2004Date d'inscription 27 avril 2012 Dernière intervention - 4 avril 2009 à 17:48
0
Merci
Salut,

Vous devez ajouter dans le fichier de configuration une phrase de passe secrète (blowfish_secret)
= >
Tu devrais lire la doc de phpMyAdmin (cf Documentation.html à la racine du dossier d'install)
La chaîne "blowfish_secret" permet de crypter les données du cookie.
Il y a un onglet "privilèges" qui te permet de gèrer les droits et les utilisateurs

PHP ne peut charger l'extension mcrypt, veuillez vérifier votre configuration de PHP
=>
je vais avoir du mal à être plus explicite.
Il faut que tu compiles PHP avec l'extension mcrypt, tout comme tu le ferais pour activer les sockets, GD2, etc ...

Kohntark -
Commenter la réponse de kohntark
cs_inaden 619 Messages postés mercredi 4 avril 2007Date d'inscription 27 août 2010 Dernière intervention - 4 avril 2009 à 18:42
0
Merci
OK,
merci, pour la première je devrais me débrouiller. Pour la seconde, je crois qu'il va falloir faire plus que cette instal/utilisation à l'arrache.
Merci pour le tuyau.

Tout vient à qui sait attendre
Commenter la réponse de cs_inaden
cs_inaden 619 Messages postés mercredi 4 avril 2007Date d'inscription 27 août 2010 Dernière intervention - 4 avril 2009 à 18:52
0
Merci
Par rapport à ce que dit kohntark ( Il y a un onglet "privilèges" qui te permet de gèrer les droits et les utilisateurs ), j'ai le message suivant :
requête SQL: 

SHOWPROCESSLIST

MySQL a répondu:

#1227 - Access denied; you need the PROCESS privilege for this operation


J'ai l'impression qu'avec cette connexion localhost, je n'ai que le droit de regarder les BDD test et information exemple qui sont déjà là.
Je me penche sur tout ça demain matin... bonne soirée à tous.

Tout vient à qui sait attendre
Commenter la réponse de cs_inaden
cs_inaden 619 Messages postés mercredi 4 avril 2007Date d'inscription 27 août 2010 Dernière intervention - 4 avril 2009 à 19:19
0
Merci
Juste pour ceux qui suivent.
J'ai réussi à me connecter en root grace au fait de mettre un mot de passe via le terminal avec la phrase :
/usr/local/mysql/bin/mysqladmin -u root password 'password'
Ce qui m'ouvre le droit de créer une base !!!!
J'ai toujours les deux petits problèmes dont je parle plus haut. Et comme documentation.html est en anglais... et bien, je remercie le type qui a traduit tout ça.
Pour les gens comme moi la doc sur phpMyAdmin est là
Il y a de grandes chances pour que je revienne vous voir demain.

Tout vient à qui sait attendre
Commenter la réponse de cs_inaden
cs_inaden 619 Messages postés mercredi 4 avril 2007Date d'inscription 27 août 2010 Dernière intervention - 5 avril 2009 à 08:25
0
Merci
Rebonjour,
pour le problème :
Vous devez ajouter dans le fichier de configuration une phrase de passe secrète (blowfish_secret)
C'est ok, il suffisait effectivement d'attribuer une valeur à :
$cfg['blowfish_secret'] = 'ba17c1ec07d65003';

Par contre pour : PHP ne peut charger l'extension mcrypt, veuillez vérifier votre configuration de PHP
=>
je vais avoir du mal à être plus explicite.
Il faut que tu compiles PHP avec l'extension mcrypt, tout comme tu le ferais pour activer les sockets, GD2, etc ...

Je ne comprends pas vraiment ce que cela veut dire. Si quelqu'un a une piste. Merci d'avance

Tout vient à qui sait attendre
Commenter la réponse de cs_inaden
cs_inaden 619 Messages postés mercredi 4 avril 2007Date d'inscription 27 août 2010 Dernière intervention - 5 avril 2009 à 08:54
0
Merci
Dans le fichier php.ini j'ai trouvé la ligne :
;extension=php_mcrypt.dll
J'ai virer le ; qui semble désactiver la ligne devant laquelle elle figure mais cela ne change pas le problème.
Compiler php avec mcrypt est-ce donner accès à une librairie, changer une ligne de code dans un fichier de configuration ???
J'ai bien trouver des trucs sur le net dont un dossier libmcryp2.5.8 et mcrypt2.6.8 Mais je ne sais pas quoi en faire... où les placer sachant que je suis sur mac et que je travaille avec le serveur du système.

Merci d'avance pour les tuyaux

Tout vient à qui sait attendre
Commenter la réponse de cs_inaden
kohntark 3708 Messages postés lundi 5 juillet 2004Date d'inscription 27 avril 2012 Dernière intervention - 5 avril 2009 à 08:55
0
Merci
Salut Inaden,

Je ne comprends pas vraiment ce que cela veut dire. Si quelqu'un a une piste. Merci d'avance
=>
Je ne veux pas être désagréable, mais je pense que tu devrais faire l'effort de chercher un peu.
Il m'a fallu moins de 15 secondes pour trouver ça :
http://fr.php.net/manual/fr/install.macosx.php
http://fr.php.net/manual/fr/mcrypt.setup.php

Tout comme ta question sur blowfish_secret il suffit de lire la doc pour avoir la réponse. Réponse qui sera 1000 fois plus compréhensible que n'importe quel commentaire sur ce forum.
Si après tu butes sur des problèmes concrets ce lieu est tout indiqué.

Bon courage,

Kohntark -
Commenter la réponse de kohntark
cs_inaden 619 Messages postés mercredi 4 avril 2007Date d'inscription 27 août 2010 Dernière intervention - 5 avril 2009 à 09:03
0
Merci
Le problème c'est que je ne comprends pas l'anglais !!!!

Tout vient à qui sait attendre
Commenter la réponse de cs_inaden
kohntark 3708 Messages postés lundi 5 juillet 2004Date d'inscription 27 avril 2012 Dernière intervention - 5 avril 2009 à 09:10
0
Merci
Arf, il y a donc pire que moi

J'ai eu pitié, les liens que je t'ai indiqués sont en French.

Cordialement,

Kohntark -
Commenter la réponse de kohntark
cs_inaden 619 Messages postés mercredi 4 avril 2007Date d'inscription 27 août 2010 Dernière intervention - 5 avril 2009 à 09:18
0
Merci
Exacte... je m'en suis aperçu après.
Je me retrouve donc avec ces deux "bibliothèques" et je cherche comment les placer au bon endroit et les relier.
En tout cas, merci de ton aide.

Tout vient à qui sait attendre
Commenter la réponse de cs_inaden
cs_inaden 619 Messages postés mercredi 4 avril 2007Date d'inscription 27 août 2010 Dernière intervention - 5 avril 2009 à 10:12
0
Merci
Bon, voila, j'ai :
Rechercher et supprimer la ligne suivante dans le fichier php.ini :
extension_dir = “./”

décommenter
extension=php_msql.dll
extension=php_mssql.dll
extension=php_mysql.dll
extension=php_mysqli.dll
extension=php_pdo_mssql.dll
extension=php_pdo_mysql.dll
extension=php_mcrypt.dll

ajouter
 extension=mcrypt.so

Sauf que cela ne fonctionne toujours pas. Je pense qu'i faut mettre quelque part ce dossier libmcrypt que j'ai télécharger mais nulle part je ne trouve l'explication qui me dit où.

Tout vient à qui sait attendre
Commenter la réponse de cs_inaden
kohntark 3708 Messages postés lundi 5 juillet 2004Date d'inscription 27 avril 2012 Dernière intervention - 5 avril 2009 à 10:42
0
Merci
Je ne sais pas où tu as trouvé ça, mais ça m'étonnerait que ce soit dans les liens que je t'ai donné.
J'ai l'impression que tu mélanges mac os et windows.
Pour quelles raisons ne suis tu pas les indications de la doc ? (cf liens)
Si tu éprouves des difficultés à compiler php pourquoi n'utilises tu pas les paquets ? (cf liens)
Tu devrais peut être poster un nouveau sujet là dessus : "compiler extension php sous mac OS"

Cordialement,

Kohntark -
Commenter la réponse de kohntark
cs_inaden 619 Messages postés mercredi 4 avril 2007Date d'inscription 27 août 2010 Dernière intervention - 5 avril 2009 à 10:55
0
Merci
Tu as raison, je suis trop co... Je vais essayer de suivre les instructions à la lettre.

Tout vient à qui sait attendre
Commenter la réponse de cs_inaden
cs_inaden 619 Messages postés mercredi 4 avril 2007Date d'inscription 27 août 2010 Dernière intervention - 5 avril 2009 à 11:20
0
Merci
En fait, j'ai les foies de foutre le bordel. Le premier lien que tu m'as donné propose de réinstaller apache ou d'autres trucs, et ça me fait flipper. Je sais, c'est pas très malin, mais comme ma config actuelle me permettait de bosser en php (sans mysql dont je n'avais pas besoin jusqu'ici étant débutant en php), j'ai un peu peur de tout casser.

J'ai envie d'apprendre à me servir des BDD, mais pas de risquer de foutre en l'air ma config, or, le premier lien que tu m'a donné propose des installation de truc dont je ne sais pas comment il vont agir, et pour le second lien, j'ai bien télécharger ce qu'ils disent, mais "suivez les instruction"... et bien, ce que je crois être des instructions sont en anglais (et j'ai eu trois ans de suite une prof d'anglais qui se servait d'un livre dont la spetième édition datait de 56). Bref, non seulement l'anglais est loin, mais enplus j'avais complètement laché.

Donc je suis devant un double problème : un problème technique et un problème humain (je flippe !)
Désolé de t'avoir fait perdre ton temps, je vais essayé de me raisonner et de suivre les instructions.

Tout vient à qui sait attendre
Commenter la réponse de cs_inaden
kohntark 3708 Messages postés lundi 5 juillet 2004Date d'inscription 27 avril 2012 Dernière intervention - 5 avril 2009 à 12:08
0
Merci
je n'ai pas perdu mon temps, je cherche à aider, tout simplement. Pour le coup je suis limite, ne connaissant pas mac os.

Poste un nouveau sujet avec un titre similaire à celui que je te proposais, tu auras plus de chance d'obtenir des réponses de personnes qui maitrisent mieux le sujet que moi.

Pour ce qui est de mcrypt, ça ne doit pas être bloquant en soi, tu dois pouvoir t'en passer pour l'instant.

Cordialement,

Kohntark -
Commenter la réponse de kohntark
cs_inaden 619 Messages postés mercredi 4 avril 2007Date d'inscription 27 août 2010 Dernière intervention - 5 avril 2009 à 12:16
0
Merci
Thank you ! Et je vais suivre ton conseil et ouvrir un autre poste sur cette histoire de compilation.
1000 merci pour ton aide et ta patience, ça m'a pas mal aidé.

Tout vient à qui sait attendre
Commenter la réponse de cs_inaden

Vous n'êtes pas encore membre ?

inscrivez-vous, c'est gratuit et ça prend moins d'une minute !

Les membres obtiennent plus de réponses que les utilisateurs anonymes.

Le fait d'être membre vous permet d'avoir un suivi détaillé de vos demandes et codes sources.

Le fait d'être membre vous permet d'avoir des options supplémentaires.