Erreur de ora-12560

mina0880 Messages postés 1 Date d'inscription mercredi 6 juin 2007 Statut Membre Dernière intervention 28 avril 2008 - 28 avril 2008 à 12:39
Alexandre Marlot Messages postés 18 Date d'inscription vendredi 13 avril 2007 Statut Membre Dernière intervention 1 mai 2008 - 1 mai 2008 à 21:59
Bonjour à tous

j'essaie de me connecter sur une base de données oracle 10g à partir de ASP.NET (visual studio 2003); j'utilise Oracleclient ; il me renvoit l'erreur suivante :
ORA-12560: TNS : erreur d'adaptateur de protocole
j'ai installé le ODAC1020221. si j'utilise le Toad, forms, reports ou winform, ça marche très bien ; y'a t'il des paramètrages à faire coté DBA ? quelqu'un peut il m'aider ???

voici la trace :

OracleException: ORA-12560: TNS : erreur d'adaptateur de protocole
]
   System.Data.OracleClient.DBObjectPool.GetObject(Object owningObject, Boolean& isInTransaction)
   System.Data.OracleClient.OracleConnectionPoolManager.GetPooledConnection(String encryptedConnectionString, OracleConnectionString options, OracleConnection owningObject, Boolean& isInTransaction)
   System.Data.OracleClient.OracleConnection.OpenInternal(OracleConnectionString parsedConnectionString, Object transact)
   System.Data.OracleClient.OracleConnection.Open()
   SI_HRMS.WebForm2.Page_Load(Object sender, EventArgs e) in c:\inetpub\wwwroot\SI_HRMS\WebForm2.aspx.vb:41
   System.Web.UI.Control.OnLoad(EventArgs e)
   System.Web.UI.Control.LoadRecursive()
   System.Web.UI.Page.ProcessRequestMain()

1 réponse

Alexandre Marlot Messages postés 18 Date d'inscription vendredi 13 avril 2007 Statut Membre Dernière intervention 1 mai 2008
1 mai 2008 à 21:59
Extrêment bizard ...
J'utilise visual studio 2005 et oracle 10G et je n'ai jamais eu cette erreur ! (pourtant j'en ai déjà eu pas mal lol !)
Rejoignez-nous