Accents, caractères spéciaux et Robots !!! [Résolu]

Signaler
Messages postés
136
Date d'inscription
lundi 26 mai 2003
Statut
Membre
Dernière intervention
13 avril 2009
-
Messages postés
136
Date d'inscription
lundi 26 mai 2003
Statut
Membre
Dernière intervention
13 avril 2009
-
Bonjour à tous,


J'essaie de pousser le référencement de mon site et je m'appercois que les robots ne voient pas mes pages comme je le souhaiterais à cause des accents et caractères spéciaux. Certes je connais la balise Meta (<meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1">) qui traite tout ce qu'il y a dans le HEAD. Pour tout le reste de mes pages, contenu chargé dynamiquement depuis mes bases de données (Ce contenu s'affiche correctement) mais les robots n'interprètent pas ces accents !!!


Que dois-je faire, reprendre tout mon code serveur et convertir chaque accent que je réceptionne, du type é==>&eacute; ?

1 réponse

Messages postés
136
Date d'inscription
lundi 26 mai 2003
Statut
Membre
Dernière intervention
13 avril 2009

Ok pb sans doute trivial pour certains d'où l'absence  de réponse, je donne quand même la soluce au cas où certains soient intéressés. Tout vient du Web.config dans lequel en VS 2003 le tag globalization déclare un encodage UTF8 en request et response, donc il suffit de changer comme ça. Et les robots comprennent les accents de toutes les données réceptionnées dynamiquement....

<

globalizationrequestEncoding="
ISO-8859-1"
responseEncoding="
ISO-8859-1"
/>