Formula et Range

Signaler
Messages postés
20
Date d'inscription
samedi 8 octobre 2005
Statut
Membre
Dernière intervention
22 janvier 2007
-
Messages postés
20
Date d'inscription
samedi 8 octobre 2005
Statut
Membre
Dernière intervention
22 janvier 2007
-
Dans une macro excel, j'ai ceci

Range("A7").Formula = "=SI(D24>0,D24,0)"

OK ça marche mais pas top.

1. Déjà le 0 à la fin du SI j'aimerais que ce soit une chaine vide comme ""
2. Dans Excel il me sort #NOM? alors que la formule est juste...

A ne plus rien y comprendre.

Une idée SVP...

1 réponse

Messages postés
20
Date d'inscription
samedi 8 octobre 2005
Statut
Membre
Dernière intervention
22 janvier 2007

Cherchez plus, j'ai trouvé :

Range("A7").Formula = "=IF(D24>0,D24,"""")"

C'est nickel.