Problème driver odbc visual foxpro

Signaler
Messages postés
6
Date d'inscription
mardi 1 février 2005
Statut
Membre
Dernière intervention
10 février 2005
-
Messages postés
6
Date d'inscription
mardi 1 février 2005
Statut
Membre
Dernière intervention
10 février 2005
-
Bonjour,

je travail avec un fichier excel, que j enregistre au format dbase 4 puis je passe par le driver visual foxpro pour travailler avec un logiciel d etiquetage pour l appel a la base de donnee.

mes caracteres sont correctes avec excel, mais qd j ouvre le tableur livré avec mon logiciel d etiquetage, les caracteres ne correspondent plus ( le é devient une virgule, le signe degré devient un phi).
Est ce que quelq un connait se problème et sait comment remedier a celui ci.

je vous en remercie

2 réponses

Messages postés
1251
Date d'inscription
mercredi 7 août 2002
Statut
Modérateur
Dernière intervention
10 avril 2013

Hello laurent,

ce problème provient soit du driver foxpro soit du format de stockage Dbase, je sais plus lequel des 2 (ça fait longtemps que j'ai plus utilisé cette technologie). Si j'ai bon souvenir il faut formater les caractères spéciaux, je te conseil de te référer à la documentation de foxpro ou de Dbase.

Bàt

Nickadele
Messages postés
6
Date d'inscription
mardi 1 février 2005
Statut
Membre
Dernière intervention
10 février 2005

salut,

il s agit apparement d un probleme de conversion oem des caracteres entre les deux lies au codepage et d apres ce que j ai pu lire ds les groupes de google, je ne suis pas le seul a avoir ce probleme.

J ai utilise le pilote odbc visual foxpro pour eviter a la personne qui bosse avec moi d utiliser un vrai tableur du style paradox ou access, trop galere pour le former a ce type de soft, je pensais qu en le faisant travailler avec un fichier excel enregistrer au format dbase que ce serait plus facile pour lui et moins d ennui pour moi.

Merci ta reponse, et si j arrive a trouver la solution, je la ferai passer.

A plus