Problème avec un lien javascript [Résolu]

Signaler
Messages postés
30
Date d'inscription
jeudi 14 mai 2009
Statut
Membre
Dernière intervention
11 février 2011
-
Messages postés
30
Date d'inscription
jeudi 14 mai 2009
Statut
Membre
Dernière intervention
11 février 2011
-
J'ai créé un bouton à l'aide de javascript.
Celui fonctionne correctement sous IE mais pas sous FF.

Voici le code

echo"getBaseUrl()."/".$ressource->controller."/".$ressource->action."');" >".$ressource->label."";



et l'erreur de debug

 
function onclick(event) {
window.location.href is not a function3 window.location.href("/Fichier/listeprofils");
}

3 réponses

Messages postés
197
Date d'inscription
mardi 20 janvier 2004
Statut
Membre
Dernière intervention
20 février 2013
1
bonjour,

echo"getBaseUrl()."/".$ressource->controller."/".$ressource->action."';" >".$ressource->label.""; 


devrait mieux fonctionné

bonne journée
Messages postés
4933
Date d'inscription
samedi 1 juillet 2006
Statut
Membre
Dernière intervention
2 février 2015
11
Bonjour,
et oui... ce n'est pas une fonction
quelques explications ici sur SelfHTML
et à propos, pour ce message ce n'est pas grave,
mais dans d'autres circonstances, comment on
devine ce que génère le php ?
il faut mettre la page html résultante !!!!
Cordialement [mon Site] [M'écrire] Bul
Messages postés
30
Date d'inscription
jeudi 14 mai 2009
Statut
Membre
Dernière intervention
11 février 2011

Ben oui évident désolé sur ce coup là j'ai merdé ... dur dur la fin de semaine

En tout cas merci pour la réponse et la rapidité