Problème de compilation composant VCL

Signaler
Messages postés
3
Date d'inscription
samedi 2 juin 2007
Statut
Membre
Dernière intervention
5 mai 2009
-
Messages postés
3
Date d'inscription
samedi 2 juin 2007
Statut
Membre
Dernière intervention
5 mai 2009
-
Bonjour,

j'utilise DELPHI 7. Je dois faire des modifications sur un logiciel développé en delphi.
j'ouvre donc mon projet et j'installe les composants nécessaires dont ceux de la VCL.

Mon problème est que je rencontre une erreure de compilation sur une unité qu s'appele : VCLUtils

voici l'erreure en question :
[Erreur] VCLUtils.pas(374): Type Object ou Class requis,

obtenue sur le code suivant :

"function MakeModuleBitmap(Module: THandle; ResID: PChar): TBitmap;
{$IFNDEF WIN32}
var
  S: TStream;
{$ENDIF}
begin
  Result := TBitmap.Create;
  try
{$IFDEF WIN32}
    if Module <> 0 then begin
      if LongRec(ResID).Hi = 0 then
        Result.LoadFromResourceID(Module, LongRec(ResID).Lo)
      else
        Result.LoadFromResourceName(Module, StrPas(ResID));
    end
    else begin
      Result.Handle := LoadBitmap(Module, ResID);
      if Result.Handle = 0 then ResourceNotFound(ResID);
    end;
{$ELSE}"

si il ya quelqu'un qui veut bien m'éclairer dessus svp ?

Merci bien

2 réponses

Messages postés
4297
Date d'inscription
samedi 19 janvier 2002
Statut
Modérateur
Dernière intervention
9 janvier 2013
31
Cette unité VCLUtils est-elle livrée par Borland ?
Si non, à quelle librairie appartient-elle ?

May Delphi be with you !
<hr color="#008000" />Pensez à cliquer sur Réponse acceptée lorsque la réponse vous convient.
Messages postés
3
Date d'inscription
samedi 2 juin 2007
Statut
Membre
Dernière intervention
5 mai 2009

cette unité appartient au composant JCL/JVCL. donc j'ai essayé de télécharger d'autres versions de ce composant, je l'installe, mais à chaque j'ai toujours les memes problèmes.

donc là je ne sais pas trop quoi faire