Message d'erreur

Signaler
Messages postés
40
Date d'inscription
mardi 29 janvier 2008
Statut
Membre
Dernière intervention
3 juin 2009
-
Messages postés
15814
Date d'inscription
jeudi 8 août 2002
Statut
Modérateur
Dernière intervention
4 mars 2013
-
Salut

Lorsque j'essaye d'installer mon application, le message suivant apparaît :

*** Erreur: Impossible de lancer le programme d'installation principal (CreateProcess() renvoie le code d'erreur 0x000000C1H)

Que faire ? Merci

3 réponses

Messages postés
15814
Date d'inscription
jeudi 8 août 2002
Statut
Modérateur
Dernière intervention
4 mars 2013
120
Salut,

Je présume qu'il s'agit d'un setup fait avec l'assistant de VB6 ... Utilise InnoSetup à la place : l'assistant de VB6 est complètement dépassé pour produire des installations marchant correctement sur Windows XP, et encore moins sous vista !

Voir mes tutoriaux à ce sujet pour savoir comment faire un setup avec InnoSetup en quelques clics.
______________________________________
DarK Sidious
Messages postés
40
Date d'inscription
mardi 29 janvier 2008
Statut
Membre
Dernière intervention
3 juin 2009

salut

merci beaucoup pour la repense j'ai téléchargé le toturial et les logiciels innosetup et istools, j'ai suivi les etapes mais a la fin ,quand je fait  Build/compile
la ligne suivante est selexionné avec le rouge

AdminPrivilegesRequired=true
je la met en commentaire    
 ; AdminPrivilegesRequired=true


mais est ce que sa va me causer des problemes par la suite ?

A+
Messages postés
15814
Date d'inscription
jeudi 8 août 2002
Statut
Modérateur
Dernière intervention
4 mars 2013
120
Salut,

Il te suffit de regarder dans la base de connaissance d'innosetup :

Une petite recherche sur google, et hop tu as ta réponse :
http://www.jrsoftware.org/iskb.php?vb

Je cite :
In order for the files with the restartreplace flag to
install successfully on Windows NT/2000/XP, the user must have
administrative privileges. By default, Inno Setup installations do not
check for administrative privileges. It is recommended that make your
installation script check for this, by setting the PrivilegesRequired [Setup] section directive:

[Setup]
...
PrivilegesRequired=admin
...

If this is not done, and the user doesn't have administrative
privileges, an "Access Denied" error message will be displayed during
the installation.

______________________________________
DarK Sidious