Détecter GD2

Résolu
Signaler
Messages postés
296
Date d'inscription
lundi 2 septembre 2002
Statut
Membre
Dernière intervention
28 janvier 2008
-
Messages postés
296
Date d'inscription
lundi 2 septembre 2002
Statut
Membre
Dernière intervention
28 janvier 2008
-
Bonjour,

Je cherche comment détecter si un serveur PHP a la library GD 1.3 ou 2.0

Mon probleme:
La fonction imagecopyresampled() existe sous les deux versions, mais elle marche seulement pour GD2 (dans mon cas).

Bizarre que function_exists('imagecopyresampled') sous GD 1.3 soit "True" alors que son usage provoque un avertissement en sortie...

Olivier D. alias ze kat  =(°o°)=
http://dzolivier.life-line.miaouw.net

2 réponses

Messages postés
1406
Date d'inscription
mercredi 17 août 2005
Statut
Membre
Dernière intervention
28 août 2007
9
Salut,

Tu connais www.php.net ?
C'est la doc de PHP... Elle te donnera la réponse en deux trois mouvements:

http://www.php.net/manual/fr/function.gd-info.php
Messages postés
296
Date d'inscription
lundi 2 septembre 2002
Statut
Membre
Dernière intervention
28 janvier 2008

Mercccccciiiiii

re-Bizarre que je n'avais pas vu cette fonction :op

Olivier D. alias ze kat  =(°o°)=
http://dzolivier.life-line.miaouw.net