Erreur CTL_E_INVALIDPROPERTYVALUE

Signaler
Messages postés
96
Date d'inscription
mardi 15 mai 2007
Statut
Membre
Dernière intervention
29 janvier 2009
-
Messages postés
7393
Date d'inscription
mercredi 23 avril 2003
Statut
Membre
Dernière intervention
6 avril 2012
-
J'ai cette erreur avec un objet MSCOMM32.OCX.. (MSComm)

Erreur 380 "CTL_E_INVALIDPROPERTYVALUE "

Des idées ?

Marco

5 réponses

Messages postés
7393
Date d'inscription
mercredi 23 avril 2003
Statut
Membre
Dernière intervention
6 avril 2012
58
Salut,
Là comme ca NON.
Mais en revanche Si tu nous dit à quel moment exactement l'erreur se produit, on pourra peu être plus t'aider. Meme sur quelle propriété.

@+: Ju£i?n
Pensez: Réponse acceptée
Messages postés
96
Date d'inscription
mardi 15 mai 2007
Statut
Membre
Dernière intervention
29 janvier 2009

MSComm.Output = Asc(21) (A l'écriture donc du port série)

Alors que la configuration et lecture de l'objet MSComm se passent très bien.

Merci,
Marco
Messages postés
7393
Date d'inscription
mercredi 23 avril 2003
Statut
Membre
Dernière intervention
6 avril 2012
58
Salut,
Lorsque l'on regarde l'explorateur d'objet (F2) et que l'on se place sur OutPut de l'objet MSCOMM on voit
Property Output As Variant
   Membre de MSCommLib.MSComm
   Écrit une chaîne de caractères dans le tampon d'émission.
, ----
[code.aspx?ID= 41455 By Renfield]

Essaie donc
MSComm.Output = Cstr(Asc( 21 ))

@+: =89254 Ju£i?n
Pensez: Réponse acceptée
Messages postés
96
Date d'inscription
mardi 15 mai 2007
Statut
Membre
Dernière intervention
29 janvier 2009

Super, ça marche... Merci.

Marco
Messages postés
7393
Date d'inscription
mercredi 23 avril 2003
Statut
Membre
Dernière intervention
6 avril 2012
58
Salut,
Si ton problème est résolu, alors penses à appuyer sur le bouton réponse acceptée sur le ou les posts qui ont pu t'aider à le résoudre.

Cela aidera les autres à mieux trouver la solution si ils rencontrent le même problème

@+: Ju£i?n
Pensez: Réponse acceptée