Problàme d'images avec IE

Signaler
Messages postés
9
Date d'inscription
samedi 10 décembre 2005
Statut
Membre
Dernière intervention
3 avril 2006
-
Messages postés
275
Date d'inscription
samedi 4 juin 2005
Statut
Membre
Dernière intervention
28 avril 2006
-
Bonjour tout le monde !

Voici mon problème :
je dois créer un site pour une plage, et ceci pour fin avril .
le nom de la plage c'est "Le palmier d'or" j'ai donc décider de mélanger le bleu avec l'or .
j'ai donc créer des images avec photoshop . après avoir créer une bannière, 5 boutons et 2 séparations, je les places en prenant compte de Mozilla . j'était plutôt contant de mon bébut, jusqu'au moment ou j'ai ouvert le site avec IE !!
il met le fond de mes images en blanc ... alors que mozilla le met en transparant ...
j'ai uper tout ça pour que vous puissiez voir la catastrophe :

http://palmierdor.sup.fr/

y a il un moyen de régler ça sans me retaper la construction des images ?

Merci d'avance



Tom le magicien

10 réponses

Messages postés
275
Date d'inscription
samedi 4 juin 2005
Statut
Membre
Dernière intervention
28 avril 2006
9
Salut,

Si c'est des images .PNG c'est normal, c'est un bug de IE, mets tes images en *.GIF
Messages postés
9
Date d'inscription
samedi 10 décembre 2005
Statut
Membre
Dernière intervention
3 avril 2006

voila c'est fait ...mais ça donne toujours le meme resulta !! :s
Messages postés
275
Date d'inscription
samedi 4 juin 2005
Statut
Membre
Dernière intervention
28 avril 2006
9
Il ne faut pas simplement changer l'extension, il faut créer un vrai GIF transparent ...
Messages postés
9
Date d'inscription
samedi 10 décembre 2005
Statut
Membre
Dernière intervention
3 avril 2006

oui je crois que c'est bien ce que j'ai fais :
j'ai ouvert mes anciennes images avec photoshop, et je les ai réenregistrer en .gif .
sous mozilla, ça marche toujours très bien ... et sous IE c'est toujours pareil :(
Messages postés
275
Date d'inscription
samedi 4 juin 2005
Statut
Membre
Dernière intervention
28 avril 2006
9
Regarde ici
Messages postés
9
Date d'inscription
samedi 10 décembre 2005
Statut
Membre
Dernière intervention
3 avril 2006

:D Dac merci bien :P j'ai compris d'ou venais le problème ... IE n'accepte pas la transparance des PNG malgres ce que microsoft avai promi ...
mais comment se fait-il que mes .GIF ne marchent toujours pas ?
Messages postés
275
Date d'inscription
samedi 4 juin 2005
Statut
Membre
Dernière intervention
28 avril 2006
9
Parce que tes GIF n'en sont pas, lorsque je tente de les enregistrer, j'obtiens par exemple ce nom de fichier:

banniere.GIF.png

Voici ce que j'obtiens en éditant le fichier en mode Hexadécimal:

Comme tu peux le voir, l'entête est PNG et non pas GIF.
Messages postés
275
Date d'inscription
samedi 4 juin 2005
Statut
Membre
Dernière intervention
28 avril 2006
9
Essaie avec ce fichier:
Messages postés
9
Date d'inscription
samedi 10 décembre 2005
Statut
Membre
Dernière intervention
3 avril 2006

Genial ça marche merci beaucoup !!
pourtant je croyais les avoir enregistrer en .gif avec photoshop ... est ce que tu pourais m'expliquer ce que tu as fait pour que je puisse le refaire sur mes autres images ?

Tom le magicien
Messages postés
275
Date d'inscription
samedi 4 juin 2005
Statut
Membre
Dernière intervention
28 avril 2006
9
Salut,

C'est Phil le magicien ...

Non, je plaisante, j'ai utilisé le premier truc que j'avais sous la main, en l'occurence Microsoft Photo Editor v3.0

J'y ai chargé ton logo et j'ai gentiment demandé à MicPhotEd d'en faire un GIF transparent... et il l'a fait

Je pense que tu peux aussi utiliser MS Paint. Je ne comprends pas pourquoi Photoshop ne te génère pas des GIF...