Datagrid en vb.net : problème d'affichage avec des tables liées.. HELP needed..

TrafMaxime Messages postés 288 Date d'inscription mercredi 4 mai 2005 Statut Membre Dernière intervention 26 janvier 2012 - 14 févr. 2006 à 11:48
cs_310 Messages postés 21 Date d'inscription dimanche 6 août 2006 Statut Membre Dernière intervention 28 avril 2012 - 27 nov. 2009 à 07:23
Salut tout le monde..

Après avoir parcouru le forum sur les datagrids, j'ai un problème irrésolu, si quelqu'un pouvait corriger ce code, je lui serais grandement reconnaissant..

Le problème est le suivant : je fais une requête sur des tables liées que je charge ds un dataset et que j'affiche joliment dans un datagrid. Tout fonctionne sauf les modifs visuelles du datagrid :
dim str as string "select t1.c1, t1.c2, t2.cc1, t2.cc2 from T1 inner join T2 on t1.c1 t2.cc2 where c2 like '"+param+"'"
dim dastr as new oledbdataadapter (str, oledbconnection1)
dim dst as new dataset()
dst.clear()
dastr.fill(dst, "t1")
datagrid1.datasource = dst.tables("t1")
datagrid1.suspendlayout()

dim ag as new datagridtablestyle()
dim bg as datagridcolumnstyle()
bg = new datagridtextboxcolumn()
bg.mappingname = "cc1"
bg.headertext = "ce que je veux de toute façon ça marche pas.."
bg.width = 80
ag.gridcolumnstyles.add(bg)
'idem pour les autres colonnes...

ag.mappingname = "t1"
ag.alternatingbackcolor = color.aliceblue
datagrid1.tablestyles.add(ag)
datagrid1.resumelayout()

Je ne sais pas vraiment quoi faire.. d'autant que ce code marche très bien pour les tables non liées...
D'avance merci (enfin j'espère..)

.Maytheforcebewithyou.Maxime.

4 réponses

olixelle Messages postés 506 Date d'inscription vendredi 30 juillet 2004 Statut Membre Dernière intervention 3 mars 2008 2
14 févr. 2006 à 19:11
ton code a l'air correct...
que se passe t il réellement ?
as tu essayé un simple refresh sur la datagrid a la fin ?

Rollerman
0
TrafMaxime Messages postés 288 Date d'inscription mercredi 4 mai 2005 Statut Membre Dernière intervention 26 janvier 2012 1
15 févr. 2006 à 08:10
Merci pout ta présence Rollerman, mais aussi incroyable que cela puisse paraître, et bien ce même code a fini par marcher..(c'est vrai qu'il a l'air bon..), mais c'est à n'y rien comprendre... après 3-4 tentatives infructueuses... une recompilation et 'hop c'est dans la boîte...

Merci,
0
cs_310 Messages postés 21 Date d'inscription dimanche 6 août 2006 Statut Membre Dernière intervention 28 avril 2012
27 nov. 2009 à 07:21
Bonjour
j'ai le meme problème que vous
" Le problème est le suivant : je fais une requête sur des tables liées que je charge ds un dataset et que j'affiche joliment dans un datagrid. Tout fonctionne sauf les modifs visuelles du datagrid :"
alors si vous pouvier me passer la soulution que vous avez addaptée car je vois bien que vous avez résolu le problème
et merçi d'avance
0
cs_310 Messages postés 21 Date d'inscription dimanche 6 août 2006 Statut Membre Dernière intervention 28 avril 2012
27 nov. 2009 à 07:23
Bonjour
Bonjour
j'ai le meme problème que vous
problème d'affichage avec des tables liées
" Le problème est le suivant : je fais une requête sur des tables liées que je charge ds un dataset et que j'affiche joliment dans un datagrid. Tout fonctionne sauf les modifs visuelles du datagrid :"
alors si vous pouvier me passer la soulution que vous avez addaptée car je vois bien que vous avez résolu le problème
et merçi d'avance
0