Erreur phpMyAdmin

Signaler
Messages postés
215
Date d'inscription
jeudi 19 décembre 2002
Statut
Membre
Dernière intervention
19 février 2009
-
Messages postés
9433
Date d'inscription
mardi 9 octobre 2001
Statut
Membre
Dernière intervention
13 avril 2007
-
Salut !

Après avoir configuré un serveur Web IIS6 / PHP5 suivant la procédure présente à l'adresse : http://odelmotte.developpez.com/tutoriels/iis/iis6phpmysql/.

Suite à cela les pages php fonctionnent.
Par contre lorsque je souhaite lancer phpMyadmin (http://localhost/phpmyadmin) j'ai l'erreur suivante :

Warning: require_once(./libraries/grab_globals.lib.php) [function.require-once]: failed to open stream: No such file or directory in C:\phpMyAdmin\index.php on line 8

Fatal error: require_once() [function.require]: Failed opening required './libraries/grab_globals.lib.php' (include_path='.;C:\php5\pear') in C:\phpMyAdmin\index.php on line 8

Kesako ?

Merci

Y.C
A voir également:

6 réponses

Messages postés
10839
Date d'inscription
lundi 24 février 2003
Statut
Modérateur
Dernière intervention
2 mars 2010
23
Hello,

heu, ton localhost, c'est la racine de ton disque C ... ??? Enfin, t'as fait un alias vers C ?
Bref, y a un blème de configuration de tes répertoires racine web, et de l'emplacement de phpmyadmin.
Lis les includes qu'il te donne, vas voir les fichiers, et changent ces include. Ou alors, change ton installation.
Messages postés
215
Date d'inscription
jeudi 19 décembre 2002
Statut
Membre
Dernière intervention
19 février 2009

Comem c'est conseillé sur http://odelmotte.developpez.com/tutoriels/iis/iis6phpmysql/, j'ai installé le site, php5 et mysql sur d: et et phpmyadmin sur c:
Messages postés
10839
Date d'inscription
lundi 24 février 2003
Statut
Modérateur
Dernière intervention
2 mars 2010
23
phpmyadmin est conseillé sur d\www\phpmyadmin, sur ton site...
phpmyadmin DOIT être dans le répertoire (ou un des répertoires) que tu gèreras en racine www.
Regarde bien les include, encore une fois, et change les en fonction de ton installation. Là, ils vont chercher des fichiers qui n'existent pas.
Messages postés
9433
Date d'inscription
mardi 9 octobre 2001
Statut
Membre
Dernière intervention
13 avril 2007
8
Salut,

"

phpmyadmin est conseillé sur d\www\phpmyadmin, sur ton site..."

exact, sinon faut que tu fasses un alias dans le httpd.conf (à l'instar d'easyphp)

Alias /mysql/ "${path}/phpmyadmin/"

<Directory "${path}/phpmyadmin">
Options FollowSymLinks Indexes
AllowOverride None
Order deny,allow
allow from 127.0.0.1
deny from all
</Directory>

tu vois le genre ?

a +
<hr size="2" width="100%"><li>Entraide, dépannage et vulgarisation informatique : Mon site de vulgarisation informatique</li><li>Codes-php.net</li>
Messages postés
10839
Date d'inscription
lundi 24 février 2003
Statut
Modérateur
Dernière intervention
2 mars 2010
23
Sous IIS ... ?
Messages postés
9433
Date d'inscription
mardi 9 octobre 2001
Statut
Membre
Dernière intervention
13 avril 2007
8
Oh putain .... la bourde,

bon je sors... un peu d'air frais me fera du bien

<hr size="2" width="100%"><li>Entraide, dépannage et vulgarisation informatique : Mon site de vulgarisation informatique</li><li>Codes-php.net</li>