Probleme dde compilation

Signaler
Messages postés
16
Date d'inscription
lundi 12 septembre 2005
Statut
Membre
Dernière intervention
9 novembre 2005
-
Messages postés
20
Date d'inscription
jeudi 9 octobre 2008
Statut
Membre
Dernière intervention
2 octobre 2009
-
je travaille sur un projet en asp.net
j'ai fais la chaine de connexion ci_dessous pour e connecter mais lors de la compilation me le compilateur me donne l'erreur suivante :"Les instructions d'assignation 'Let' et 'Set' ne sont plus prises en charge."
<%
set conn = Server.CreateObject("ADODB.Connection")
' chaine de connexion
connstring = "driver={Microsoft ODBC for Oracle};" & "server=drh;uid=login; pwd=mot de passe; database=ma base"
' ouverture de la connexion
conn.open connstring
set Rs = Server.CreateObject("ADODB.Recordset")
' traitement
req= "select distinct DOTI,NOM_PRENOM,LOCALITE from PERSONNEL order by DOTI asc "
Rs.open req,Conn
' fermeture et destruction de la connexion
conn.close
set conn=nothing
%>
que dois je faire? aidez moi svp

2 réponses

Messages postés
1642
Date d'inscription
samedi 6 novembre 2004
Statut
Modérateur
Dernière intervention
28 avril 2011
2
Cette méthode de connexion à une base de données est celle utilisée en ASP et pas en ASP.NET !!



Je te conseille ce petit tutorial sur la Connexion aux bases de données en ASP.NET.



De plus, la méthode nommée "Set" n'existe pas en asp.net !! Elle vient
elle aussi de l'ASP (plus précisément du VBScript utilisé en ASP),
hors, en asp.net, on utilise VB.NET à la place de VBScript !! Donc je
te conseille aussi un petit tutorial surla syntaxe VB.NET (pour oublier cette syntaxe ASP de plus en plus...dépassée ) !


A++

Nurgle
Il est plus aisé d'être sage pour les autres que pour soi-même ! (La Rochefoucauld)
Messages postés
20
Date d'inscription
jeudi 9 octobre 2008
Statut
Membre
Dernière intervention
2 octobre 2009

bonjour tout le monde


je suis debutante en asp .J'ai voulu compiler un truc et le message suivant s'est affiché ("Error while trying to run project:Enable to start debugging on the web server.Debugging failed because integrated windows authen(tification is not enabled") je ne sais vraiment pas quoi faire


merci d'avance