Driver jdbc et classpath !!!!

Résolu
cs_jimmy69
Messages postés
778
Date d'inscription
dimanche 22 décembre 2002
Statut
Membre
Dernière intervention
27 novembre 2008
- 9 sept. 2005 à 15:43
cs_jimmy69
Messages postés
778
Date d'inscription
dimanche 22 décembre 2002
Statut
Membre
Dernière intervention
27 novembre 2008
- 11 sept. 2005 à 18:21
Bonjour a tous,

Ne m'en voulez pas mais je debute en java ...!!!!

Voila je vous explique ce que je ne comprends pas et le p'tit souci que je rencontre !

J'essaye de me connecter a mysql en local j'ai donc bien sur installer le serveur de base de donnees fait une classe de connection (recopie d'un livre ) et placer le driver de connection le fichier jar donc dans le repertoire de mon application

quand le lance le tout il me fait le catch => class introuvable ...

le connecteur est donc mal place je pense !!!!
j'ai essaye de le mettre dans le dossier src puis class mais cela ne change rien !!!!
Apres avoir regarde sur l'ami google j'ai vu qu'il fallait l'enregister avec classpath mais la je ne vois pas comment faire !

quelqu'un aurait il une idée !

Je vous remercie

Christophe
//Source
package connectionp;


//Importation
import java.sql.*;

public class TestConnectionJDBC {
//CONSTRUCTEUR
public TestConnectionJDBC() {
}
/**********************************/



public static void main(String[] args) {
TestConnectionJDBC testconnectionjdbc = new TestConnectionJDBC();
//Variable connection
Connection connection = null;
//Bloc try catch
try{
Class.forName("com.mysql.jdbc.Driver");
connection = DriverManager.getConnection("jdbc:mysql:///base");
JOptionPane.showMessageDialog(null, "Connection ok");
}
catch(ClassNotFoundException ex){
JOptionPane.showMessageDialog(null,"Classe introuvable "+ ex.getMessage());
}
catch(SQLException ex){
JOptionPane.showMessageDialog(null,"Connection impossible" + ex.getMessage());
}
//finally
finally
{
try{
if(connection !=null){
connection.close();
}
}catch(SQLException ex){
ex.printStackTrace();
}
}
System.exit(0);
}
}

6 réponses

cs_neodante
Messages postés
2835
Date d'inscription
lundi 11 août 2003
Statut
Modérateur
Dernière intervention
16 décembre 2006
11
9 sept. 2005 à 22:44
Effectivement le classpath est indispensable ... met sle dans le
dossier lib ou jre/lib/ext qui est contenu dans le classpath par défaut
sinon lance ton prog avec l'option -classpath ...



Sur le forum il y a déjà de nombreux posts qui répondent exactement à ton problème ... ;-)



++
3
cid019
Messages postés
237
Date d'inscription
mercredi 2 juin 2004
Statut
Membre
Dernière intervention
11 juillet 2006

9 sept. 2005 à 15:52
Peux-tu donner le message d'erreur complet stp?

cid019
0
cs_jimmy69
Messages postés
778
Date d'inscription
dimanche 22 décembre 2002
Statut
Membre
Dernière intervention
27 novembre 2008
1
9 sept. 2005 à 16:02
qd j'execute l'application voici ce qu'il me dit

classe introuvable : com.mysql.jdbc.Driver

je suis sur que cela vient du connecteur qu'il n'arrive pas a trouver ...je ne sais pas ou le placer !!!!!

dans quel repertoire !!!!

Merci

Christophe
0
cid019
Messages postés
237
Date d'inscription
mercredi 2 juin 2004
Statut
Membre
Dernière intervention
11 juillet 2006

9 sept. 2005 à 16:15
Je sais pas, moi j'installe mysql tout simplement (sous windows) et
tout se passe bine, j'ai jms eu aucun probleme, bizarre ton truc. A
moins que ce soit ta chaine de connection qui ne soit pas la bonne.

cid019
0

Vous n’avez pas trouvé la réponse que vous recherchez ?

Posez votre question
cs_jimmy69
Messages postés
778
Date d'inscription
dimanche 22 décembre 2002
Statut
Membre
Dernière intervention
27 novembre 2008
1
9 sept. 2005 à 16:29
je suis sous winxp aussi

comment fais tu pour te connecter a mysql en java!?

dans le livre il dise qu'il faut placer le connecteur fichier .jar dans le classpath !!!!!

Merci

Christophe
0
cs_jimmy69
Messages postés
778
Date d'inscription
dimanche 22 décembre 2002
Statut
Membre
Dernière intervention
27 novembre 2008
1
11 sept. 2005 à 18:21
Salut salut

Merveilleux ...ca tourne !

Je vous remercie tous de votre patience et vous souhaite une excellente semaine ..

Christophe
0