Erreur compilation [Résolu]

Signaler
Messages postés
18
Date d'inscription
mardi 28 octobre 2003
Statut
Membre
Dernière intervention
15 juin 2006
-
Messages postés
18
Date d'inscription
mardi 28 octobre 2003
Statut
Membre
Dernière intervention
15 juin 2006
-
Bonjour,
Je n'arrive pas à compiler ma dll activex. Une erreur s'affiche:
"Aucun composant public ne peut être créé."

Merci de m'apporter une solution

3 réponses

Messages postés
1114
Date d'inscription
jeudi 19 décembre 2002
Statut
Membre
Dernière intervention
6 mai 2007

Tu doit avoir un composant style Usercontrol ou autre qui a sa propriété 'Public' sur true.

@Z3RtY25 ==
3
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

Codes Sources 195 internautes nous ont dit merci ce mois-ci

Messages postés
18
Date d'inscription
mardi 28 octobre 2003
Statut
Membre
Dernière intervention
15 juin 2006
1
Merci aux 2 interlocuteurs qui se sont donnés la peine de me répondre.
Le problème était une mauvaise affectation à la propriété "instancing" de mon module de classe. Elle était à private au lieu de multiuse.
Messages postés
1488
Date d'inscription
mercredi 5 février 2003
Statut
Membre
Dernière intervention
3 décembre 2007
22
Ou alors que tu as déclaré (utilisé) un truc (objet,
composant ActiveX, DLL) au mauvais endroit!!! Ne t'indique-t-il pas une
ligne de code précise ??? (attention car parfois c'est celle juste au
dessus qui pose problème!!!). Sans code on ne peut pas faire grand
chose pour toi tu sais!!!



Au fait, précise toujours sous quel language tu programmes, c'est
important pour qu'on puisse t'aider efficacement (et aussi pour nous
éviter de perdre du temps) !!!



Enjoy

<hr size="2" width="100%">

(Si une réponse vous convient, cliquez sur le bouton "Réponse accéptée"...)