Service NT - Grrrrr

Signaler
Messages postés
11
Date d'inscription
jeudi 14 novembre 2002
Statut
Membre
Dernière intervention
19 novembre 2002
-
Messages postés
21
Date d'inscription
mardi 8 mai 2001
Statut
Membre
Dernière intervention
18 février 2010
-
Salut a tous !

Voila je vous explique mon probleme :
- g fait une appli vb6 qui marche tres bien
- je l'ai mis en service NT

-> le service est bien créé effectivement mais l'appli de se lance jamais au demarrage.
-> En y regardant de plus pres, quand je vais dans le gestionaire de services de XP et que je clique sur demarrer le service (il y a une petite fenetre avec une barre de progression qui s'ouvre) ca me dis au bout d'une seconde : <<Erreur 1503 le service n'a pas repondu assez vite a la demande de lancement ou de controle>>

Au début je me suis dit que je devais mal créé le service, g donc essayé plusieurs techniques :

- le bon vieux srvany ou on met une clé parameters et une chaine application dans le service qu'a créé srvany
->> srvany se lance au démarrage, malheureusement c bien le seul a se lancer

- un code vb6 qui consiste en deux module BasRegistry et BasService d'une 800 aine de lignes pris sur un site de sources
->> tjrs pareil

- le code vb6 qu'on trouve sur les forums de VBfrance sous une forme plus ou moins bordélique
->> tjrs pareil

- g aussi essayé de le mettre tout simplement dans la clé "RUN" dans la base de registre de windows
->> se lance pas

- g aussi essayé de remplacer le .exe d'un service qui marche par mon appli ^^ ( c con, je sais :p )
->> a marche pas non plus

Je suis déséspéré.... QQ a déja eu ce probleme ? vous en pensez quoi ? c mort pour moi ?

merci a tous ceux qui vont se pencher sur la question

6 réponses

Messages postés
11
Date d'inscription
jeudi 14 novembre 2002
Statut
Membre
Dernière intervention
19 novembre 2002

Simple oubli :

- g aussi essayé l'ocx ntsvc de microsoft
->> héhé vous devinez ce que ca a donné ;)
0
Messages postés
11
Date d'inscription
jeudi 14 novembre 2002
Statut
Membre
Dernière intervention
19 novembre 2002

S'il vous plait aidez moi ca me met vraiment dans la merde ce bug :(

ya pas grand chose de particulier dans le code de mon appli, je pense pas qu'il y ait une incompatibilité avec le fait de le lancer en service mais je met quand meme les points importants de mon appli pr au cas ou :

- la form est en visible=false
- g declaré deux fct :
Private Declare Sub Sleep Lib "KERNEL32" (ByVal dwMilliseconds As Long)
Private Type coords
X As Long
Y As Long
End Type
Private Declare Function GetCursorPos Lib "user32" (LpPoint As coords) As Long
Dim curseur(1 To 2) As coords

- ya un timer
- un app.taskvisible = false (g deja essayé de l'enlever mais ca change rien au probleme )
- une ouverture de fichier txt
- quelques commandes shell
- un sock

voila c tout ... serieux je comprend pas.. je viens d'essayer le code que PROVB vient de poster aussi .. avec son prog a lui ca marche nickel... mais quand je met le code dans le miens il installe le service mais quand je veux le lancer ya tjrs erreur 1503 le service n'a pas repondu assez vite a la demande de lancement ou de controle

HELp HELP HELP
0
Messages postés
11
Date d'inscription
jeudi 14 novembre 2002
Statut
Membre
Dernière intervention
19 novembre 2002

bon ok je sors en fait g resolu le prob tt seul ^^
0
Messages postés
67
Date d'inscription
mercredi 27 février 2002
Statut
Membre
Dernière intervention
2 décembre 2005

Est ce qu'il te serait possible de m'envoyer par mail ton code celui de 800 lignes du service (je suis interessé) par la version sans ntsrv....

ybidoli@areks.com

Merci. (peut etre que je pourrais identifier ton pb)
0
Messages postés
33
Date d'inscription
vendredi 30 janvier 2004
Statut
Membre
Dernière intervention
15 mai 2008

j'ai actuellement le meme probleme que tu as eu il y a quelques mois.
Si tu pouvez me dire ce que tu as trouvé pour ne plus avoir ce grrrrr message d'erreur, je pourrez enfin continuer mon aventure vers d'autres soucis.

merci beaucoup.

a+
0
Messages postés
21
Date d'inscription
mardi 8 mai 2001
Statut
Membre
Dernière intervention
18 février 2010

Si tu es d'accord , vus que j'ai le problème que tu as eu il y as un bon bout de temps.
si tu serrais m'envoyer ta soluce celà m'arrangerais beaucoups...
D'avance merci.

@pluche . Bowlman
0