NullReferenceException: Object reference not set to an instance of an object...

Signaler
Messages postés
6
Date d'inscription
dimanche 8 août 2004
Statut
Membre
Dernière intervention
26 avril 2011
-
Messages postés
1642
Date d'inscription
samedi 6 novembre 2004
Statut
Modérateur
Dernière intervention
28 avril 2011
-
Bonjoir ^^,

Quelqu'un pourrait-il me dire où ça cloche ? Je suis vraiment noob donc le moindre petitindice serait le bienvenu ;)

L'erreur suivante se produit quand je valide un formulaire login/mot de passe.

[NullReferenceException: Object reference not set to an instance of an object.]
declaweb.Login.ValidAuthentication()
declaweb.Login.btOK_ServerClick(Object sender, EventArgs e)
System.Web.UI.HtmlControls.HtmlInputButton.OnServerClick(EventArgs e) +108
System.Web.UI.HtmlControls.HtmlInputButton.System.Web.UI.IPostBackEventHandler.RaisePostBackEvent(String eventArgument) +57
System.Web.UI.Page.RaisePostBackEvent(IPostBackEventHandler sourceControl, String eventArgument) +18
System.Web.UI.Page.RaisePostBackEvent(NameValueCollection postData) +33
System.Web.UI.Page.ProcessRequestMain() +1277

Par avance merci

Aeterna
A voir également:

4 réponses

Messages postés
1642
Date d'inscription
samedi 6 novembre 2004
Statut
Modérateur
Dernière intervention
28 avril 2011
2
Salut,

Et bien, euh...il faudrait voir le code, sinon on risque d'avoir du mal

<hr size="2" width="100%">Nurgle (Antoine)
Messages postés
6
Date d'inscription
dimanche 8 août 2004
Statut
Membre
Dernière intervention
26 avril 2011

Bonjour,

Le problème c'est qu'il y en a tellement et que je suis complètement étranger à tout ça. Selon les premières indications à quel niveau ca peut clocher ?

Merci pour votre aide

Aeterna :)
Messages postés
73
Date d'inscription
mardi 15 mars 2005
Statut
Membre
Dernière intervention
18 novembre 2010

L'erreur suivante : NullReferenceException: Object reference not set to an instance of an object
Tu dois avoir oublié d'instancier un objet, certainement "declaweb"

Mais sans le code en effet pas facile :)

Keikun59
Messages postés
1642
Date d'inscription
samedi 6 novembre 2004
Statut
Modérateur
Dernière intervention
28 avril 2011
2
Je ne pense pas que c'est "declaweb" qu'il a oublié d'instancier vu que c'est dans la méthode "declaweb.Login.ValidAuthentication()" de son objet "declaweb" que l'erreur est lancée : c'est le code de cette méthode qu'il faudrait nous montrer, ou même le code de sa méthode appellante : "declaweb.Login.btOK_ServerClick(Object sender, EventArgs e)".

Sinon, tu peux aussi lancer la page en Debug (vive Visual Studio ) et tu verras comme ça exactement la ligne qui génère l'erreur

<hr size="2" width="100%">Nurgle (Antoine)