Problème visual studio et opencv

isil4 Messages postés 15 Date d'inscription vendredi 28 novembre 2008 Statut Membre Dernière intervention 18 janvier 2012 - 18 janv. 2012 à 14:45
cs_Lucky92 Messages postés 180 Date d'inscription mercredi 22 décembre 2004 Statut Membre Dernière intervention 16 août 2012 - 19 janv. 2012 à 07:21
Bonjour,

j'ai l'erreur :
1>main.cpp
1>c:\opencvold\include\opencv\cv.h(63) : fatal error C1083: Cannot open include file: 'opencv2/core/core_c.h': No such file or directory
1>Build log was saved at "file://chemin\testOpenCV\Debug\BuildLog.htm"
1>testOpenCV - 1 error(s), 0 warning(s)
======== Build: 0 succeeded, 1 failed, 0 up-to-date, 0 skipped ==========




j'ai suivi ces tutoriels:
http://opencv.itseez.com/doc/tutorials/introduction/windows_visual_studio_Opencv/windows_visual_studio_Opencv.html#windows-visual-studio-how-to
http://knol.google.com/k/opencv-2-0-installation-et-configuration#
http://opencv.itseez.com/doc/tutorials/introduction/windows_install/windows_install.html#installation-by-making-your-own-libraries-from-the-source-files

J'ai l'impression que c'est un problème de variables d'environnement, mais je comprend pas le quel???

Les executables de la librairies marchent après compilation (visual studi, build open cv). Donc le problème ne vient pas d'open cv mais des linkers, mais c'est quoi exactement :-((((


S'il vous plait help.
Merci!

1 réponse

cs_Lucky92 Messages postés 180 Date d'inscription mercredi 22 décembre 2004 Statut Membre Dernière intervention 16 août 2012 2
19 janv. 2012 à 07:21
Bonjour,

C'est un problème de compilation, puisque le compilateur dit qu'il n'arrive à ouvrir un include.
1/ As-tu vérifié que l'include en question est bien à l'endroit indiqué ?
2/ Dans visual studio sous "Outils/Options/Projets et Solutions/Répertoires de VC++/Fichier Include", as-tu ajouté le chemin "c:\opencvold\include" ?

@++
0