Compter les cellules ayant un critère [Résolu]

Messages postés
35
Date d'inscription
mercredi 25 mai 2011
Dernière intervention
3 mai 2012
- - Dernière réponse : ucfoutu
Messages postés
18039
Date d'inscription
lundi 7 décembre 2009
Statut
Contributeur
Dernière intervention
11 avril 2018
- 22 juin 2011 à 19:10
Bonjour tout le monde,

j'aimerais savoir comment compter le nombre de cellule comportant des "1" (par exemple)

Suis-je obligé de faire une boucle ou peut-on utiliser une formule de type
MsgBox Application.WorksheetFunction.CountA(Range("A2:A65536"))

mais en utilisant des critères pour le comptage.


Merci d'avance

;)
Afficher la suite 

Votre réponse

2 réponses

Meilleure réponse
Messages postés
18039
Date d'inscription
lundi 7 décembre 2009
Statut
Contributeur
Dernière intervention
11 avril 2018
259
3
Merci
Bonjour,
Il suffit d'utiliser la fonction Excel NB.SI

exemple :
placée dans une cellule :
=+NB.SI(A1:A3;2)

y inscrira le nombre de cellules contenant 2 dans la plage A1:13



____________________
Vous aimez Codes-Sources ? Il vous aide ? Cliquez ici pour l'aider à continuer
Cliquer sur "Réponse acceptée" en bas d'une solution adéquate est

Dire « Merci » 3

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

Codes Sources 90 internautes nous ont dit merci ce mois-ci

Commenter la réponse de ucfoutu
Messages postés
41
Date d'inscription
samedi 30 avril 2011
Dernière intervention
26 juin 2012
0
Merci
Salut,

Il te faut faire une boucle sur la plage de cellule déterminée avec la condition de comptage.

exemple:



Sub test()
Dim compteur
For Each c In Range("A1:A12")'plage déterminée
If c 1 Then 'condition, si cellule 1
compteur = compteur + 1' compteur
End If
Next
MsgBox ("nbr cellule contenant '1' : " & compteur & " . ")

End Sub

Peut etre que ce bout de code t'aidera :)
Commenter la réponse de boomer11

Vous n'êtes pas encore membre ?

inscrivez-vous, c'est gratuit et ça prend moins d'une minute !

Les membres obtiennent plus de réponses que les utilisateurs anonymes.

Le fait d'être membre vous permet d'avoir un suivi détaillé de vos demandes et codes sources.

Le fait d'être membre vous permet d'avoir des options supplémentaires.