Pb. synschronisation d'un son (mp3) et de l'animation au démarrage

pesant Messages postés 3 Date d'inscription mercredi 8 janvier 2003 Statut Membre Dernière intervention 29 mars 2003 - 29 mars 2003 à 14:04
cs_tom Messages postés 1511 Date d'inscription samedi 8 décembre 2001 Statut Modérateur Dernière intervention 11 juin 2009 - 31 mars 2003 à 12:46
Pb. synschronisation d'un son (mp3) et de l'animation au démarrage

J'ai une animation (relativement simple), des lettres apparaissent au rythme de la musique (qui est lente).
En local sur ma machine tout va bien, la synchro est parfaite, je vois mes lettres arriver (sous forme d'animation) en même temps que ma musique.
Dés que je mets ça sur une page Web, sur le serveur AVEC ou sans preload (qui me permettrait de démarrer la musique qd je veux) ça devient n'importe quoi !

quelqu'un peut m'aider ? JE SUIS EN TRAIN DE M'ARRACHER LES CHEVEUX DE LA TETE !!!

Merci.

3 réponses

cs_tom Messages postés 1511 Date d'inscription samedi 8 décembre 2001 Statut Modérateur Dernière intervention 11 juin 2009
29 mars 2003 à 16:12
Salut,

le mieux est de mettre ton son sur un calque seul, et de mettre la case "sync" en "continu". De cette maniere, si ton anim a des ralentissements, il zappe des images pour que le son soit fluide et en rythme avec ton anim...

@+ tom
0
pesant Messages postés 3 Date d'inscription mercredi 8 janvier 2003 Statut Membre Dernière intervention 29 mars 2003
29 mars 2003 à 16:16
Merci, j'étais en train de constater que c'était mieux avec cette option, mais le fichier son semble se charger avant le reste et démarre toujours au démarrage mais avec les phénomèes de cache avec IE 6 c'est vraiment galère, cela fait des années que je bosse sur le web, depuis peu je me suis mis à flash MX (et flash tout court) et je vois qu'il y aussi pas mal de truc "bizarre" avec flash !

merci à toi qd même

si d'autres ont d'autres conseils à ce sujet je suis preneur
0
cs_tom Messages postés 1511 Date d'inscription samedi 8 décembre 2001 Statut Modérateur Dernière intervention 11 juin 2009
31 mars 2003 à 12:46
Ben flash j'y touche depuis pas mal de temps (j'ai commencé à la version 4, il y a 4 ans) et si tu veux une synchronisation parfaite, il ne faut pas utiliser de clip, puisque par définition, il sont indépendant de la scene (donc pas synchronisé), contrairement au graphique. De plus, si tu as coché la case "continu" pour le son, il ne se charge pas en une seule fois, mais image par image: le son est découpé, justement pour pouvoir etre synchronisé par rapport à la scene.

Les seuls trucs 'bizarre' dans flash, ce sont les décalages de pixel pour le bitmap, qui peuvent etre contournés soit en décalant les images d'un demi pixel, soit en réduisant la taille de l'anim d'un pixel.

Y a pas de probleme de cache, meme sous IE6, puique les swf se chargent en streaming (sauf que c'est à toi de le controler en programmation).

@+ Tom
0