Disparition d'un bouton lors de l'application de la macro (probleme perso)

Signaler
Messages postés
30
Date d'inscription
mercredi 9 avril 2008
Statut
Membre
Dernière intervention
10 février 2011
-
Messages postés
13280
Date d'inscription
lundi 13 décembre 2004
Statut
Modérateur
Dernière intervention
3 février 2018
-
Bonjour a tous

Voila j'ai un petit probleme que je ne comprends pas du tout, est ce que quelqu'un pour me l'expliquer? Merci

donc: j'ai une macro et dans cette macro a un instant t je fais apparaitre un bouton dans une feuille. Lorsque j'effectue la macro en pas à pas (F8) tout va bien, mon bouton apparait.
Mais quand j'effectue la macro en vitesse normal, mon bouton n'apparait pas.

D'ou peut venir ce bug?

voici une partie du code:
[...]If TextBox3.Text " toto" And TextBox4.Text pass Then
   
    UserForm1.Hide
   
    Call Module1.toto


Sheets("Feuil1").Activate
[...]

-----(module 1)---

Public Sub toto()
Sheets("feuil1").Activate              


Sheets("feuil1").Visible = True           
Sheets("feuil1").Unprotect PassWord:=pass 


Sheets("feuil3").Activate
    Sheets("feuil3").CommandButton1.Visible = True


End Sub

Merci bonne journée

RoX

1 réponse

Messages postés
13280
Date d'inscription
lundi 13 décembre 2004
Statut
Modérateur
Dernière intervention
3 février 2018
39
salut,

ajoute DOEVENTS à la fin de ta sub toto, pour donner une fraction de seconde de répit....

++

<hr size="2" width="100%" />
Prenez un instant pour répondre à [forum/sujet-SONDAGE-POP3-POUR-CS_769706.aspx ce sondage] svp