Image de fond [Résolu]

Signaler
Messages postés
93
Date d'inscription
lundi 3 juillet 2006
Statut
Membre
Dernière intervention
25 juin 2010
-
Messages postés
93
Date d'inscription
lundi 3 juillet 2006
Statut
Membre
Dernière intervention
25 juin 2010
-
J'aimerai afficher une image de fond sans utiliser la propriété bgcolor de
pour plus de possibilités. J'ai fait ce code qui fonctionnait avec FrontPage et IE,
mais j'ai récemment changé de navigateur, et je me suis rendu compte que ce code
ne marchait pas avec Mozilla Firefox ...
Voici mon code (en simplifié) :

<html>

bonjour

</html>

L'image n'apparaît pas sur Mozilla bien qu'elle soit présente dans :
Informations sur la page>Médias. En retirant le "z-index: -1;", l'image apparaît,
mais au dessus du texte. Comment faire ?

Merci d'avance.

7 réponses

Messages postés
13616
Date d'inscription
jeudi 13 février 2003
Statut
Membre
Dernière intervention
15 octobre 2013
33
ah... je commence à comprendre ce que tu veux....

bonjour

<hr />                Cordialement            Bul         [mon Site]     [M'écrire]
Messages postés
469
Date d'inscription
mercredi 9 janvier 2002
Statut
Membre
Dernière intervention
20 février 2017
5
Salut !!!!
Et pourquoi pas le css ?
<style>
    body{
       background-umage:url("./BGPic.jpg");
    }
</style>

beaucoup plus simple non ?

[o-_-o]
Messages postés
93
Date d'inscription
lundi 3 juillet 2006
Statut
Membre
Dernière intervention
25 juin 2010

Dans ce cas, comment faire pour que l'image prenne la dimension de l'écran,
et comment faire pour la déplacer ? (top, left, width, height)
Messages postés
13616
Date d'inscription
jeudi 13 février 2003
Statut
Membre
Dernière intervention
15 octobre 2013
33
Bonjour,

    et pourquoi un z-index = -1 ?
    à partir de 0, tout baigne....

<hr />                Cordialement            Bul         [mon Site]     [M'écrire]
Messages postés
93
Date d'inscription
lundi 3 juillet 2006
Statut
Membre
Dernière intervention
25 juin 2010

J'ai déjà essayé quelque chose comme ça, mais ça ne marche pas ...

<html>

bonjour

</html>
Messages postés
469
Date d'inscription
mercredi 9 janvier 2002
Statut
Membre
Dernière intervention
20 février 2017
5
en fait c'est juste un problème de z-Index !

[o-_-o]
Messages postés
93
Date d'inscription
lundi 3 juillet 2006
Statut
Membre
Dernière intervention
25 juin 2010

Oui, c'est ce que je cherchais.
Merci !!!

(et merci aussi pour le "filter:alpha(opacity=50); -moz-opacity: 0.5;" que je
ne connaissait pas non plus).