Modif timeout dans web.config non pris en compte [Résolu]

equinoxe83 240 Messages postés lundi 18 juin 2007Date d'inscription 18 février 2011 Dernière intervention - 30 oct. 2007 à 10:43 - Dernière réponse : equinoxe83 240 Messages postés lundi 18 juin 2007Date d'inscription 18 février 2011 Dernière intervention
- 26 mars 2008 à 15:16
Bonjour à tous,
j'ai un Pb de deconnexion au bout de 20 mn que je n'arrive pas à régler.
C'est un site intranet utilisé par une dizaine de personnes. Je souhaite modifier le timeout à 120 mn.
Malgré la modif dans le web.config de (voir plus bas), le timeout est tjs à 20mn ...

J'ai essayé de modifier les paramètres sur IIS (également à 20mn) sur mon serveur (2003) mais c'est la même chose.
L'autentification est faite par formulaire.Ci dessous une partie du web.config utilisé.
Merci de votre aide!
Frédéric

<?xml version="1.0"?>


<configuration>
 
 <connectionStrings>
 




  </connectionStrings>
 <system.web>


  
 
   
     
     
      <deny users="?" />
   
  <compilation debug="true" strict="false" explicit="true">
   
    
    
    </compilation>
  
   <namespaces>
    <clear/>
    
    
    
    
    
    
    
    
    
    
    
    
    
    
    
   </namespaces>
  


    <caching>
      <sqlCacheDependency enabled="true" pollTime="500">
        <databases>
         
        </databases>
      </sqlCacheDependency>
    </caching>
  
  <roleManager enabled="true"
                 defaultProvider="CustomizedRoleProvider">
     
       
     

    </roleManager>
   
    <membership defaultProvider="CustomizedProvider">
     
       
     

    </membership>


<sessionState mode="InProc" timeout="120" >
  
      <clear />
  

</sessionState> 




  </system.web>
</configuration>
Afficher la suite 

6 réponses

Répondre au sujet
Jean_Marc_1968 20 Messages postés jeudi 22 septembre 2005Date d'inscription 22 décembre 2008 Dernière intervention - 26 mars 2008 à 13:13
+3
Utile
D'après moi le problème vient juste du fait que j'ai oublié la balise fermante de l'authentification dans le bout de code que je t'ai donné.

Voici un extrait d'un web.config qui fonctionne très bien sur un site :

    <formsname=".ASPXAUTH"loginUrl="~/Public/Login.aspx"defaultUrl="~/default.aspx"timeout="60"></forms>

    <denyusers="?"/>
   
>

@+,
Jean-Marc
Cette réponse vous a-t-elle aidé ?  
Commenter la réponse de Jean_Marc_1968
equinoxe83 240 Messages postés lundi 18 juin 2007Date d'inscription 18 février 2011 Dernière intervention - 8 nov. 2007 à 07:40
0
Utile
Je réactive le mail ...
Y-a personne pour le donner une info sur ce point ???
Commenter la réponse de equinoxe83
Commenter la réponse de cs_zarroug
Jean_Marc_1968 20 Messages postés jeudi 22 septembre 2005Date d'inscription 22 décembre 2008 Dernière intervention - 20 mars 2008 à 19:11
0
Utile
Salut,

Tu as effectivement un timeout de session et ta session est bel et bien timée à 120min. Toutefois, comme tu n'as pas mis de timeout pour ton autentification de form, tes forms restent valides 20min. Tu devrais essayer comme ceci :

 
   <forms timeout ="120"></forms>
   
     
     
      <deny users="?" />
   

Je pense que ton problème doit venir de là.


Ceci dit, depuis le temps que tu cherches la réponse, je me dis que tu dois déjà l'avoir trouvée, mais comme je suis passé sur ton post par hasard, je me dis que ça pourrait arriver à d'autres et que cette solution pourrait les aider.


@+,
Jean-Marc
Commenter la réponse de Jean_Marc_1968
equinoxe83 240 Messages postés lundi 18 juin 2007Date d'inscription 18 février 2011 Dernière intervention - 21 mars 2008 à 10:07
0
Utile
Salut et merci de ta réponse ... même tardive c'est toujours utile de comprendre pourquoi!
Celà dit, j'ai tenté ta solution et j'ai le soucis de config suivant :

Erreur de configuration
Description : Une erreur s'est produite lors du traitement d'un fichier de configuration requis pour répondre à cette demande. Veuillez consulter ci-dessous les détails relatifs à l'erreur en question, puis modifier votre fichier de configuration de manière appropriée.

Message d'erreur de l'analyseur: Section de configuration non reconnue system.web/forms.

Erreur source:

Ligne 36 :
Ligne 37 :   
Ligne 38 : <forms timeout = "120"> </forms>
Ligne 39 :     
Ligne 40 :       


Mon web.config (extraction du system.web)

<system.web>
 <customErrors mode="Off"/>
 
 <forms timeout = "120"> </forms>
     
        
        
        <deny users="?" />
     
 <sessionState mode="InProc" timeout="120" >
     
         <clear />
     

 </sessionState> 
</system.web>

Pour la petite histoire, j'ai changé mon appli de serveur et le Pb est réglé (juste avec le sessionState à 120 (par contre, je n'ai plus le mode="InProc").

Merci d'avance pour ton aide!!
Commenter la réponse de equinoxe83
equinoxe83 240 Messages postés lundi 18 juin 2007Date d'inscription 18 février 2011 Dernière intervention - 26 mars 2008 à 15:16
0
Utile
Bingo !
Tout à fait celà !!!
Merci pour cette aide à la compréhension !!!!
Pour les intéressés, ci-dessous l'extraction de la portion du Web.config en cause.
Encore Merci à Jean Marc !
@+
Frédéric

<system.web>
 <customErrors mode="Off"/>
 
    <forms timeout = "120"> </forms>
 
 
     
     
     <deny users="?" />
 
 <sessionState mode="InProc" timeout="120" >
     
         <clear />
     

 </sessionState> 
</system.web>
Commenter la réponse de equinoxe83

Vous n'êtes pas encore membre ?

inscrivez-vous, c'est gratuit et ça prend moins d'une minute !

Les membres obtiennent plus de réponses que les utilisateurs anonymes.

Le fait d'être membre vous permet d'avoir un suivi détaillé de vos demandes et codes sources.

Le fait d'être membre vous permet d'avoir des options supplémentaires.