Probleme envois winsock

StiriX Messages postés 67 Date d'inscription jeudi 26 décembre 2002 Statut Membre Dernière intervention 2 septembre 2009 - 10 sept. 2006 à 01:27
PCPT Messages postés 13280 Date d'inscription lundi 13 décembre 2004 Statut Membre Dernière intervention 3 février 2018 - 10 sept. 2006 à 14:48
Bonjour à tous. Voici le code d'où est le problème:

Dim fs,d As Object
Dim sResult,s As String
   
    Set fs = CreateObject("Scripting.FileSystemObject")
    For Each d In fs.Drives
        If (sResult = "") Then
        sResult = d.driveletter
        Else
        sResult = sResult & "<" & d.driveletter
        End If
        sResult = sResult & s
    Next d
    Form1.Winsock1.SendData sResult

Le problème : quand je réceptionne la donnée j'obtient "??????" pourtant j'ai bien définit tout les formats ... voilà :)

1 réponse

PCPT Messages postés 13280 Date d'inscription lundi 13 décembre 2004 Statut Membre Dernière intervention 3 février 2018 49
10 sept. 2006 à 14:48
salut,

et quel est le code au niveau de la réception (socket) ?

ici ta sub un peu modifiée.....
Private Sub Command1_Click() 
    Dim fs As Object, Item As Object, sResult As String 
    sResult =  vbNullString 

    Set fs =  CreateObject ("Scripting.FileSystemObject") 
    For Each Item In fs.Drives 
        sResult  = sResult & Item.driveletter & "<" 
    Next Item 
    sResult =  LeftB$(sResult,  LenB (sResult) - 2) 

    Set Item  = Nothing 
    Set fs =  Nothing 

    Form1.Winsock1.SendData sResult 
    DoEvents 
End Sub

<small> Coloration
syntaxique automatique [AFCK] </small>
       
++

PCPT   [AFCK]
<hr size ="2" width="100%" />Prenez un instant pour répondre à ce sondage svp
0
Rejoignez-nous