Probleme de classe debutant extreme

Signaler
Messages postés
105
Date d'inscription
lundi 13 décembre 2004
Statut
Membre
Dernière intervention
14 février 2013
-
Messages postés
10839
Date d'inscription
lundi 24 février 2003
Statut
Modérateur
Dernière intervention
2 mars 2010
-
bonjour !

je vien de tester de faire ma premiere classe en php5 avec wamp et j'ai le probleme suisvant :


le code de ma classe s'affiche sur la page a lieux du resultat du traitement !

 voici le code de ma page :


<?

class Personne {

   private  $prenom;

   private  $nom;

  

   function __construct($prenom, $nom) {

       $this->prenom = $prenom;

       $this->nom = $nom;

   }

  

   function info() {

       return "$this->prenom $this->nom";

   }

}

$test = new Personne("Jean", "Bart");

echo $test->info();

?>


tres tres simple non ?

 et pourtant ... voila sur ma page ce qu'il apparait  quand je l'execute sous localhost :

prenom = $prenom;
$this->nom = $nom;
}

function info() {
return "$this->prenom $this->nom";
}
}
$test = new Personne("Jean", "Bart");
echo $test->info();
?>


au lieux de:

Jean Bart


help me please ........


(quand je regarde le code source de la page afficher par internet explorer j'obtient out le code source de la page)

2 réponses

Messages postés
2268
Date d'inscription
mercredi 27 novembre 2002
Statut
Membre
Dernière intervention
13 septembre 2013
3
Salut!
Et avec <?php au lieu de <? ?

@++

R@f

www.allpotes.ch: Photos, humour, vidéos, gags, ...
"On dit que seulement 10 personnes au monde comprenaient Einstein. Personne ne me comprends. Suis-je un génie???"
Messages postés
10839
Date d'inscription
lundi 24 février 2003
Statut
Modérateur
Dernière intervention
2 mars 2010
26
ah, short_open_tags à Off...c'est bien, mais encore faut il le respecter ;-)
Donc oui, je pense que Coockiesch voit juste.