Son en allegro

Signaler
Messages postés
9
Date d'inscription
samedi 27 mai 2006
Statut
Membre
Dernière intervention
26 juin 2007
-
Messages postés
9
Date d'inscription
samedi 27 mai 2006
Statut
Membre
Dernière intervention
26 juin 2007
-
c'est que je suis confontre a ce bleme alors s'il vous plait help me
salut tout le monde
j'ai un bleme avec les son en allegro
avec les midifile
int i=1;
play_midi(song,i);
et le son se joue correctement mais quand je fais
if( .... ) 

   /* ......*/
   i=0;
 }
et le son continue de se jouer et meme  quand je fais
stop_midi(/*...*/);
le son continue de se jouer
et autre bleme
le defilement quand je fais
x++; le truc je deplace mais avec des discontinuites c'est a dire on le voit  la et tout suite il fait un grand deplacement et pour je l'ai fait  avec un timer BPS_TO_ TIMER(60) et quand je modifie le 60 en donnant 30 par exemple c'est mieux mais c'est lent
maintenat je voudrais le faire pour que ca soit rapide et qu'on le voit  comme une balle
merci a vous d'avance

6 réponses

Messages postés
16
Date d'inscription
vendredi 24 décembre 2004
Statut
Membre
Dernière intervention
28 juillet 2007

Je ne comprends pas trop bien ton problème...
Tu pourrais mettre ton code stp ?

A+
Vince Le Fou !
Messages postés
9
Date d'inscription
samedi 27 mai 2006
Statut
Membre
Dernière intervention
26 juin 2007

c'est que je suis confontre a ce bleme alors s'il vous plait help me
merci vincelefou pour les sons il son resolu mais pour l'animation le bleme subsiste
j'affiche un rectangle avec
int x=20, x1=50;
rectfill(buffer,x,50,x1,150,makecol(255,0,0));
x+=2,x1+=2;//le cadre je deplace
//mon bleme
le rectangle se deplace mais pas comme une balle dont on peut connaitre la vitesse ici il y a des discontinuite de deplacement cad il s'affiche a x=70,x1=100 puis je vois a  x=120,x1=150;
bizarre
a++
Messages postés
16
Date d'inscription
vendredi 24 décembre 2004
Statut
Membre
Dernière intervention
28 juillet 2007

C'est difficile de trouver une solution à ton problème sans voir le code.
C'est peut-être 1 problème de synchronisation à l'affichage du recfill :
Cad que tu modifies les variables x et x1 en oubliant d'afficher (et d'effacer) régulierement ton rectangle ?

Vince Le Fou !
Messages postés
9
Date d'inscription
samedi 27 mai 2006
Statut
Membre
Dernière intervention
26 juin 2007

c'est que je suis confontre a ce bleme alors s'il vous plait help me
merci vince le Fou mais mais mon code seras une surprise sur le site
je prepare un jeu tres complexe
qui je crois sera appreciez par tous
a++
Messages postés
16
Date d'inscription
vendredi 24 décembre 2004
Statut
Membre
Dernière intervention
28 juillet 2007

Salut WiKonSon,

Voici une adresse pour t'aider à programmer avec Allegro :
http://www.mangue.org/wiki/Cat%C3%A9gorie:Allegro

J'espere que cela te sera utile...

Vince Le Fou !
Messages postés
9
Date d'inscription
samedi 27 mai 2006
Statut
Membre
Dernière intervention
26 juin 2007

c'est que je suis confontre a ce bleme alors s'il vous plait help me
merci mais je le connait deja