Probleme avec WebBrowser

Signaler
Messages postés
2
Date d'inscription
dimanche 29 décembre 2002
Statut
Membre
Dernière intervention
2 janvier 2003
-
Messages postés
13
Date d'inscription
vendredi 6 juin 2003
Statut
Membre
Dernière intervention
30 janvier 2005
-
Bonjour

Voici le probleme que je rencontre, J'ai fait un prog permettant de naviguer sur le net avec un Webbrowser, j'ai la possibilite de recuperer les sources de la page qui s'affiche dedans, mais le source recuperer n'est pas exactement le meme que celui du site, Je m'explique quand dans le code source du site il y a un double voir un triple espace au niveau d'une chaine d'affichage , le source recuperer par le webbrowser n'en contient qu'un , visuellement c'est la meme chose mais si je veux exploiter cette donnees (le double espace) je ne peux pas , pouvez vous me dire comment faire pour que le source du webbrowser soit a l'identique de celui du site visite .

Merci

2 réponses

Messages postés
13
Date d'inscription
vendredi 6 juin 2003
Statut
Membre
Dernière intervention
30 janvier 2005

Bonjour à tous,

Je suis en train de dev une appli qui parse le code d'une page web rendu par le composant webbrowser.

Je récupère donc le body.innerHTML de la page afin de parser.

Le pb c'est que de manière aléatoire, il manque parfois des bout de code dans le code source rendu par body.innerHTML alors que qd je fais un clic droit > afficher source il y a tout.

Savez vous d'ou viens le pb ? Il semble que le pb est le même que la personne si dessus.

Merci
0
Messages postés
13
Date d'inscription
vendredi 6 juin 2003
Statut
Membre
Dernière intervention
30 janvier 2005

Bonjour à tous,

Je suis en train de dev une appli qui parse le code d'une page web rendu par le composant webbrowser.

Je récupère donc le body.innerHTML de la page afin de parser.

Le pb c'est que de manière aléatoire, il manque parfois des bout de code dans le code source rendu par body.innerHTML alors que qd je fais un clic droit > afficher source il y a tout.

Savez vous d'ou viens le pb ? Il semble que le pb est le même que la personne ci dessus.

Merci
0