La publication sur le serveur est un vrai casse-tête

cs_Francki Messages postés 23 Date d'inscription mercredi 19 décembre 2001 Statut Membre Dernière intervention 21 août 2008 - 6 avril 2005 à 18:03
jesusonline Messages postés 6814 Date d'inscription dimanche 15 décembre 2002 Statut Membre Dernière intervention 13 octobre 2010 - 6 avril 2005 à 20:46
Bonjour, n'étant pas un nouveau de la programmation ASP.Net, mais tout
à fait nouveau quant à la publication d'un site sur un serveur autre
que sur celui où je conçoit mon application web, ça fait maintenant
plusieurs longues heure que je n'arrive pas à pulbier mon site sur le
serveur du réseau de la comagnie pour laquelle je travaille.



Voici mon problème: j'ai un site web qui fera office d'intranet que
j'ai entièrement développé sur ma machine ayant visual studio 2003 et
iis 5.1. Lorsque je suis sur mon ordinateur et que ce dernier fait
office de serveur, je peux parfaitement visualiser mes pages (le genre
"http://localhost/intranet/indez.aspx"). Le problème vient quand je
veux le mettre sur un vrai serveur. J'ai essayé multiples et multiples
façons. J'ai même créer un setup avec VS 2003 à installer sur le
serveur web qui me créer automatiquement mon répertoire virtuel et
blablabla. Rien ne fonctionne. Au mieux, ce que je réussis à avor c'est
le listing de mon répertoire virutel et lorsque je clique sur
index.aspx ça me propose de télécharger le fichier, plutot que de
l'afficher et de le traiter.



J'attends des nouvelles de n'importe qui qui pourrait avoir une piste
de solution et j'attends encore plus quelqu'un qui m'apporte LA
solution héhéhé



Si vous manquez d'informations, n'hésitez surtout pas à m,en demander, il me fera plaisir d'éclaicir le moindre point nébuleux.

Cordiallement, François

3 réponses

jesusonline Messages postés 6814 Date d'inscription dimanche 15 décembre 2002 Statut Membre Dernière intervention 13 octobre 2010 29
6 avril 2005 à 18:32
installe le framework sur le serveur. A mon avis c'est un truc du genre ;)



sinon regiis_aspnet -i

<hr>
Cyril - MCP ASP.net
Webmaster de : Hoshimi.CodeS-SourceS.fr
0
cs_Francki Messages postés 23 Date d'inscription mercredi 19 décembre 2001 Statut Membre Dernière intervention 21 août 2008
6 avril 2005 à 19:50
Bonjour, en passant merci pour la réponse, mais maintenant l'erreur
n'est plus la même, au lieu de vouloir télécharger la source, il ne
trouve juste.... plus rien. En effet il m'affiche

__________________________________________________________

The page cannot be found


The page you are looking for might have been removed, had its name changed, or is temporarily unavailable.
<hr>
Please try the following:




<li>Make sure that the Web site address displayed in the address bar of your browser is spelled and formatted correctly.</li><li>If you reached this page by clicking a link, contact
the Web site administrator to alert them that the link is incorrectly formatted.
</li><li>Click the [javascript:history.back(1) Back] button to try another link.</li>


HTTP Error 404 - File or directory not found.
Internet Information Services (IIS)


<hr>
Technical Information (for support personnel)




<li>Go to Microsoft Product Support Services and perform a title search for the words HTTP and 404.</li><li>Open IIS Help, which is accessible in IIS Manager (inetmgr),
and search for topics titled Web Site Setup, Common Administrative Tasks, and About Custom Error Messages</li>

--------------------------------------------------------------



Pour faire des tests, j,ai décidé de mettre un fichier html
exactement à la même place que mon fichier aspx que je veux ouvrir et
celui-là ouvre toujours sans le moindre problème. Vois-tu une autre
solution ?



Merci encore, Francois
0
jesusonline Messages postés 6814 Date d'inscription dimanche 15 décembre 2002 Statut Membre Dernière intervention 13 octobre 2010 29
6 avril 2005 à 20:46
404 ca veut dire que le fichier n'existe pas, donc la c'est absolument
pas normal, que tu tombes sur une 404, t'es bien sur que tu tapes la
bonne adresse ?



redemarre IIS, si tu peux essaye de le reinstaller, mais je pense que c'est un problème d'installation du framework.


<hr>
Cyril - MCP ASP.net
Webmaster de : Hoshimi.CodeS-SourceS.fr
0