Indy 10 pièce jointe [Résolu]

ni69 1529 Messages postés samedi 12 juin 2004Date d'inscription 5 juillet 2010 Dernière intervention - 20 déc. 2004 à 22:26 - Dernière réponse : eupani33 9 Messages postés mardi 16 juin 2009Date d'inscription 28 août 2009 Dernière intervention
- 17 juil. 2009 à 14:26
Bonjour,

J'avais l'habitude, avec Indy 9, de joindre une pièce jointe à un message de cette façon (normale) :
TIdAttachment.Create(IdMessage1.MessageParts,CheminFichier);


Mais lors de la compilation avec Indy 10, il me met une erreur :
Identificateur non déclaré : 'TIdAttachment'


Savez-vous comment faire pour envoyer une pièce joiinte avec Indy 10 :question) Merci d'avance...

@+
Bonne Prog'
Nico
Afficher la suite 

Votre réponse

4 réponses

Meilleure réponse
JulioDelphi 2354 Messages postés dimanche 5 octobre 2003Date d'inscription 18 novembre 2010 Dernière intervention - 20 déc. 2004 à 23:40
3
Merci
"TIdAttachment" appartient a kel unité .pas pour le 9 ? et pour le 10 !?

N'oubliez pas de cliquer sur Réponse acceptée lorsque ma réponse vous convient ! ;)

-------------------------------------------

Merci JulioDelphi 3

Avec quelques mots c'est encore mieux Ajouter un commentaire

Codes Sources a aidé 90 internautes ce mois-ci

Commenter la réponse de JulioDelphi
Meilleure réponse
ni69 1529 Messages postés samedi 12 juin 2004Date d'inscription 5 juillet 2010 Dernière intervention - 21 déc. 2004 à 20:23
3
Merci
Ah désolé, cela doit surement venir du fait que maintenant, j'utilise la version 6 perso de delphi (le projet que j'avais développé avec Indy 9 était sur D7 pro...)

Merci quand même ! :)

@+
Bonne Prog'
Nico

Merci ni69 3

Avec quelques mots c'est encore mieux Ajouter un commentaire

Codes Sources a aidé 90 internautes ce mois-ci

Commenter la réponse de ni69
cs_Pierre42 19 Messages postés samedi 31 janvier 2004Date d'inscription 22 novembre 2008 Dernière intervention - 26 févr. 2006 à 13:17
0
Merci
Bonjour,

J'ai le meme probleme en passant de delphi 7 a delphi 2005. Le code est identique, les compasants indy 10 sont installés dans les deux cas et par moyen de faire touner le programme. J'ai toujours l'erreur " Identificateur non déclaré : 'TIdAttachment' ". Probleme c'est que le TIdAttachment n'est nulle part !

Quelqu'un a t'il la solution ?

Merci

Laurent Rigaldies
France Progiciels Distribution
www.franceprogiciels.com
Commenter la réponse de cs_Pierre42
eupani33 9 Messages postés mardi 16 juin 2009Date d'inscription 28 août 2009 Dernière intervention - 17 juil. 2009 à 14:26
0
Merci
uses IdAttachment;
Commenter la réponse de eupani33

Vous n'êtes pas encore membre ?

inscrivez-vous, c'est gratuit et ça prend moins d'une minute !

Les membres obtiennent plus de réponses que les utilisateurs anonymes.

Le fait d'être membre vous permet d'avoir un suivi détaillé de vos demandes et codes sources.

Le fait d'être membre vous permet d'avoir des options supplémentaires.