Problème Sauvegarde Projet Delphi 7 Version Portable ???

Signaler
Messages postés
9
Date d'inscription
mardi 10 octobre 2006
Statut
Membre
Dernière intervention
20 décembre 2013
-
tuss
Messages postés
9
Date d'inscription
mardi 10 octobre 2006
Statut
Membre
Dernière intervention
20 décembre 2013
-
Voila mon problème :
Depuis l'année dernière, c'est à dire ~2 mois j'utilise DELPHI Version 7.0 (Build 4.453).
Tout marchais bien jusqu'à ce jour.
J'écrit mon code, je l'exécute tout va bien.
Quand je veut sauvegarder mon projet (.dpr), ou mon Fichier (.pas)
Delphi me retourne l'Erreur suivante :

Unable to rename 'Chemin\Mon_Programme.$$$' to 'Chemin\Mon_Programme.pas'

J'ai effectivement le Fichier Temporaire : 'Chemin\Mon_Programme.$$$' dans mon Répertoire de travail.

Après diverses tentatives :
Supression du Fichier (.$$$)
Supression du Fichier (.pas)
Rien n'y fait !
Supression complète des Fichiers créés par Delphi dans le Répertoire :
'C:\Documents and Settings\Administrateur\Application Data\Thinstall\Borland Delphi 7'
Réinstallation de mon application...
Cà marche toujours pas.
(Pour une application dîtes portable, c'est quand même une belle usine à Gaz...)
Je suis coincé, et la seule solution de substitution c'est d'utiliser le BlocNote de Zindows... (Bonjour la galère !)

Quelqu'un à t'il une solution ???

Je précise que ma machine n'à aucun problème.
J'utilise d'autres applications portables et que tout va bien de ce coté là.

NANANEE à Tous et que les oracles du Code vous soit favorables.

2 réponses

Messages postés
1154
Date d'inscription
samedi 14 août 2004
Statut
Membre
Dernière intervention
5 avril 2012

Bonjour

Sous Vista ou Windows 7, il existe un problème similaire qui peut être résolu en changeant les droits d'accès au(x) répertoire(s) concerné(s) (Voir ici).
A examiner dans ton cas.

Cordialement.[hr]"L'imagination est plus importante que le savoir." Albert Einstein
Messages postés
9
Date d'inscription
mardi 10 octobre 2006
Statut
Membre
Dernière intervention
20 décembre 2013

Bonjour, WhiteHippo.

Merci pour cette piste.

Je suis sous XP-SP3
Le PC est monopost et monoutilisateur.
il démarre directement sur mon compte administrateur.
J'ai essayé de desactiviver la propriété Lecture_Seule des Fichiers et Répertoires concernés, l'opération s'éxécute sans problème, mais quand je retourne dans les propriétés, Lecture seule est de nouveau actif.