Page blanche sur datareport [Résolu]

Signaler
Messages postés
710
Date d'inscription
jeudi 20 février 2003
Statut
Membre
Dernière intervention
19 mai 2015
-
Messages postés
710
Date d'inscription
jeudi 20 février 2003
Statut
Membre
Dernière intervention
19 mai 2015
-
bonjour
dans mon prog j'ai 2 datareport qui fonctionnent trés bien.
datareport1 --> DataEnvironment1
datareport2 --> DataEnvironment2
je lance mon prog les datareport m'affiche bien les données de ma table access ,impeccable,
donc je rajoute un 3ieme datateport
datareport3 --> DataEnvironment1
je lance le prog, les datareport1 et 2 m'affiche une page blanche sans erreur et le datareport3 m'affiche bien les donneés.
dans les 2 DataEnvironment je vais chercher ma base dans le meme dossier.
DataEnvironment1 j'ai 2 commandes
commande1 :instruction SQL --> SELECT * FROM centre_aéré WHERE Num_ctr=Param1
commande2 :instruction SQL --> SELECT prenomenfant_ctr, nomenfant_ctr FROM `present_enfant`
DataEnvironment2 :
commande1 :instruction SQL --> SELECT * FROM centre_aéré WHERE Num_ctr=Param1.
je ne comprends pas pourquoi quand j'ai rajouter un troisiéme datareoprt,les 2 autres m'affiche une page blanche sans erreur.
auriez vous une idée
merci
petchy

1 réponse

Messages postés
710
Date d'inscription
jeudi 20 février 2003
Statut
Membre
Dernière intervention
19 mai 2015
3
Re
j'ai trouver d'ou vient cette page blanche.
en fait pour afficher les données sur mon datareport ,je me servait d'une données (clé primaire) qui allait sur un textbox,mais le code du texbox était effacer,donc j'ai remis se code,et la les données s'affiche.
DataEnvironment1.Commands("command1").Parameters("param1").Value = Text2.Text

petchy