WEBBROWSER TRES LENT

Signaler
Messages postés
96
Date d'inscription
mercredi 26 mai 2010
Statut
Membre
Dernière intervention
27 mai 2010
-
Messages postés
96
Date d'inscription
mercredi 26 mai 2010
Statut
Membre
Dernière intervention
27 mai 2010
-
Bonjour

j'utilise un webbrowser qui parcours des pages et éffectue des actions sur celles ci à la chaine.
Seulement je m'apercois que au bout de certains nombre de page 50 environ la navigation est trés ralenti.

J'ai chercher du coté du cache internet (Vidange réguliere) mais rien y fait.
Avez vous une idée.
Merci

3 réponses

Messages postés
114
Date d'inscription
lundi 5 février 2007
Statut
Membre
Dernière intervention
10 septembre 2010

Salut,

as-tu essayé de bien vidé le cache du webbrowser ?

How To Clear Cache When Your Application Hosts a WebBrowser Control
http://support.microsoft.com/kb/262110

Sinon, faut nous en dire plus si tu n'as pas trouvé depuis.
Messages postés
96
Date d'inscription
mercredi 26 mai 2010
Statut
Membre
Dernière intervention
27 mai 2010

Merci pour ta réponse!!
Mais j'ai lâché l'affaire avec le webrowser j'ai déjà testé la piste du cache mais cela est peu concluant.
j'utilise objHTTPRequest beaucoup plus efficace pour ce aue j'ai a faire Quitte a mettre a jour le webbrowser avec le résultat obtenu par objHTTPRequest ...
Cependant par curiosité je v voir ton lien histoire de voir si j' avais procédé de la même manière Merci
Messages postés
96
Date d'inscription
mercredi 26 mai 2010
Statut
Membre
Dernière intervention
27 mai 2010

Effectivement je n'avais pas utilisé les API mais je reste septique car pour tout te dire je vider le cache directement par internet explorer ce qui doit être l'équivalent des API(je pense...)

De plus le ralentissement ne s'effectue qu'au bout d un certains nombre de page parcourues si on redémarre l appli sans vidange de cache la cadence reprend son rythme normal jusqu'a ralentir a nouveaux aux bout d un certains nombre de page.

Mystère!!!!