Erreur impossible de definir la propriété minimumScale de la classe axis [Résolu]

simafst 37 Messages postés dimanche 20 mai 2007Date d'inscription 11 juin 2010 Dernière intervention - 21 avril 2009 à 16:41 - Dernière réponse : simafst 37 Messages postés dimanche 20 mai 2007Date d'inscription 11 juin 2010 Dernière intervention
- 22 avril 2009 à 10:49
Salut
j'ai fait un code avec VBA mais maintenant je veux le refaire avec VB6
mon code en VBA c'est le suivant(une partie)
Charts.Add
        ActiveChart.ChartType = xlXYScatterLines

With ActiveChart
  .Axes(xlValue).MinimumScale = 0
       .Axes(xlValue).MaximumScale = 100
      End With
 
         With ActiveChart
         .Axes(xlCategory).MinimumScale = freq_init
       .Axes(xlCategory).MaximumScale = freq_stop
       .Axes(xlCategory).ScaleType = xlLogarithmic
       End With
         ActiveChart.SetSourceData Source:=Sheets("feuil1").Range(str_draw)
mon probléme c'est lors de son exécution avec VB6 il me renvoie une erreur "impossible de définir la propriété MinimumScale de la classe axis (de méme pour MaximumScale, hasTitle...) je suis bloqué et je sais pas c'est le probléme
Afficher la suite 

Votre réponse

3 réponses

Meilleure réponse
cnt 219 Messages postés lundi 21 novembre 2005Date d'inscription 20 décembre 2010 Dernière intervention - 21 avril 2009 à 17:53
3
Merci
Salut
 Il faut avoir chargé la bibliothèque "Microsoft Graph 9.0 Object Library", à partir du menu "Projet" de l 'IDE VB6, ligne "Références"

CNTJC

Merci cnt 3

Avec quelques mots c'est encore mieux Ajouter un commentaire

Codes Sources a aidé 126 internautes ce mois-ci

Commenter la réponse de cnt
Meilleure réponse
simafst 37 Messages postés dimanche 20 mai 2007Date d'inscription 11 juin 2010 Dernière intervention - 22 avril 2009 à 09:31
3
Merci
Salut j'ai chargé la bibliothèque "Microsoft Graph 12.0 Object Library" dés le début et ça ne marche pas aussi :(

Merci simafst 3

Avec quelques mots c'est encore mieux Ajouter un commentaire

Codes Sources a aidé 126 internautes ce mois-ci

Commenter la réponse de simafst
simafst 37 Messages postés dimanche 20 mai 2007Date d'inscription 11 juin 2010 Dernière intervention - 22 avril 2009 à 10:49
0
Merci
ça va c'est réglé mon problème c'est que j'ai installé sur mon PC 2 version de Microsoft 2003 et 2007 quand j'ai désinstallé le 2003 ça marche :)
Commenter la réponse de simafst

Vous n'êtes pas encore membre ?

inscrivez-vous, c'est gratuit et ça prend moins d'une minute !

Les membres obtiennent plus de réponses que les utilisateurs anonymes.

Le fait d'être membre vous permet d'avoir un suivi détaillé de vos demandes et codes sources.

Le fait d'être membre vous permet d'avoir des options supplémentaires.