Besoin d'aide avec la lib vfw

Signaler
Messages postés
50
Date d'inscription
vendredi 19 mai 2006
Statut
Membre
Dernière intervention
2 juillet 2016
-
Messages postés
50
Date d'inscription
vendredi 19 mai 2006
Statut
Membre
Dernière intervention
2 juillet 2016
-
Bonjour j'ai un petit probleme avec la lib "video for windows" voila en fait sur certaine video que j'essaye de lire la video se joue normalement puis au bout de quelque seconde le son se coupe mais la video continue a tourner ou alors la video s'accade et tourne a une vitesse anormale (trop vite) ou encore la video ne se lance pas du tout sur certaine video tout marche impec je pense que c'est un probleme avec les codec mais comment utiliser les codec dejas installé pour lire mes video ? (si c'est bien le manque de codec qui me pose des problemes)

voila le code que j'ai  :

m_fenetre=MCIWndCreate(CWnd::GetSafeHwnd(),AfxGetInstanceHandle(),MCIWNDF_SHOWNAME | MCIWNDF_NOTIFYSIZE | MCIWNDF_SHOWALL|WS_VISIBLE ,NULL); // je créer une nouvelle fenetre et je recupere son handle dans (m_fenetre)

MCIWndOpen(m_fenetre,LPCTSTR(NomVideo),0);  // j'ouvre le fichier video suivant son chemin sur le disque dur

char name[100]; // tableau de caractere qui recuperera le nom de la fenetreMCIWndGetFileName(m_fenetre,name,100); // recuperation du nom de la fenetre

MCIWndPlay(m_fenetre); // lecture de la video

voila j'attend vos réponse je précise je code sous vs2005

merci d'avance

1 réponse

Messages postés
50
Date d'inscription
vendredi 19 mai 2006
Statut
Membre
Dernière intervention
2 juillet 2016

Personne ne peut m'aider ?