Send qui n'envoi pas

Signaler
Messages postés
283
Date d'inscription
mercredi 8 janvier 2003
Statut
Membre
Dernière intervention
4 juillet 2007
-
Messages postés
283
Date d'inscription
mercredi 8 janvier 2003
Statut
Membre
Dernière intervention
4 juillet 2007
-
J'utilise la commande send dans un programme. Apparemment, aucune erreur ne se déclanche et l'envoi est correct mais le serveur auquel je me suis connecté ne recoit rien (c'est aussi moi qui ai fait le serveur).

Avez-vous une idée ?

CyberP,
Celui qui dit que toute question a une réponse

4 réponses

Messages postés
157
Date d'inscription
jeudi 17 octobre 2002
Statut
Membre
Dernière intervention
11 septembre 2004

ta bien mi pour le serveur
int n = recv([...]);
if(n != 0)
{
cout << buffer;
}

Romano >:)
[mailto:romano492@hotmail.com romano492@hotmail.com]
Messages postés
283
Date d'inscription
mercredi 8 janvier 2003
Statut
Membre
Dernière intervention
4 juillet 2007
2
Le serveur n'a aucun problème (sur et certain)

Pour vous expliquer un peu, le serveur est un serveur FTP qui marche (je l'ai testé avec un client ftp trouvé sur le net) mais maintenant je voudrais faire un client FTP mais je n'arrive pas à envoyer des données...

CyberP,
Celui qui dit que toute question a une réponse
Messages postés
157
Date d'inscription
jeudi 17 octobre 2002
Statut
Membre
Dernière intervention
11 septembre 2004

essai de trouver parmi les exemples du site :-)
si tu di que ton serveur na pas de prb
Romano >:)
[mailto:romano492@hotmail.com romano492@hotmail.com]
Messages postés
283
Date d'inscription
mercredi 8 janvier 2003
Statut
Membre
Dernière intervention
4 juillet 2007
2
Oui mais j'ai fait copier-coller d'un ancien chat que j'avais fait, chat qui marchait sans aucun problème...

Ce que je voulais dire c'est s'il n'y a pas quelque chose de spécial à préciser lors de l'envoi ou quelque chose comme ca...

CyberP,
Celui qui dit que toute question a une réponse