Plantages Oracle, C#, old school...

Résolu
leprov
Messages postés
1160
Date d'inscription
vendredi 23 juillet 2004
Statut
Membre
Dernière intervention
21 octobre 2010
- 25 avril 2007 à 16:09
leprov
Messages postés
1160
Date d'inscription
vendredi 23 juillet 2004
Statut
Membre
Dernière intervention
21 octobre 2010
- 27 avril 2007 à 10:45
Bon alors le problème, j'ai fait une appli qui accède a une base oracle, en C# 1.1, par OleDB, le tout car l'application doit fonctionner sous NT avec un serveur oracle de vieille version, etc....bref, la joie d'utiliser les vieilles technos...

sous ma machine de dev (xp), tout se déroule a merveille, mais sur une machine configurée comme le pc sur site (windows NT en bref), ca plante...
au moment de l'appel a la méthode "open" de la OleDbConnection, l'erreur "la mémoire ne peut être 'read', blablabla" sort, en passant outre mes catchs etc...en bref, un beau plantage....
alors pour les questions de base, le MDAC est bien installé, le tnsname correctement configuré, le client oracle 9 est installé (et le serveur en version 8 est installé sur la même machine)....

la seule chose bizarre, cest que pendant un moment, seul oracle server était installé (pas l'oracle client), et pendant ce temps la, une exception propre survenait, spécifiant (en gros, et a ce que j'ai compris), qu'il fallait installer oracle client....

bref, si quelqu'un a une suggestion il me sauvera d'un suicide certain...

PS : la réponse "passe la machine sous XP" n'est, à mon grand désespoir, pas envisageable.....

1 réponse

leprov
Messages postés
1160
Date d'inscription
vendredi 23 juillet 2004
Statut
Membre
Dernière intervention
21 octobre 2010
17
27 avril 2007 à 10:45
bon il semblerait qu'un changement de version de MDAC + changement de version oracle client aient permis de résoudre le probleme...
3