Socket Builder: Asynchronous socket error 10049 [Résolu]

momo2007ma 3 Messages postés samedi 13 janvier 2007Date d'inscription 26 avril 2007 Dernière intervention - 13 janv. 2007 à 17:45 - Dernière réponse : momo2007ma 3 Messages postés samedi 13 janvier 2007Date d'inscription 26 avril 2007 Dernière intervention
- 10 févr. 2007 à 12:51
Bonjour tout le monde,

Mon problème est le suivant: j'ai créee un socket client builder 6 TClientSocket pour envoyer un message vers un serveur unix. Le serveur unix étant bien démarré, fonctionne bien, je l'ai testé sous unix en créant un client unix. La communication entre le client/serveur unix se passe bien. Par contre le bablesse si quantd j'essaye de connecter le client windows crée sous Builder et le server unix. un message d'eeeur s'affiche. le serveur ne reçoit rien.

Error message: Asynchronous socket error 10049

je galère depuis longtemps avec ce probleme, y'a quequ'un qui peut m'aider
merci,

Mon code:

// Creation of client socket : 
  TClientSocket *i_ClientSocket_Dest;
  i_ClientSocket_Dest = new TClientSocket(NULL);


  // server informations
  struct  hostent         *serveur;
  char *srv;
 
 serveur = gethostbyname(SERV);
  srv = serveur->h_name;
 
  // message to send
  char *buffer;

  // Initialize the socket
  i_ClientSocket_Dest->Host = "myserver";
  i_ClientSocket_Dest->Address = SERV;
  i_ClientSocket_Dest->Port = PORT;


  //Activate the connection
  i_ClientSocket_Dest->Open();
  i_ClientSocket_Dest->Active = true;


  // A test message to send to server
  buffer = "MSG: Hello";


  // Check that the connection is established
  if (i_ClientSocket_Dest->Socket->Connected == true)
          {
          i_ClientSocket_Dest->Socket->SendText(buffer);
          g_str_Message = g_str_Message + "Client Socket is Connected" + AnsiString("\n");
          }
  else
        {
                g_str_Message = g_str_Message + "Client Socket is not Connected " + AnsiString("\n");
        }


  // Close the connection
  i_ClientSocket_Dest->Close();
  i_ClientSocket_Dest->Active = False;
Afficher la suite 

Votre réponse

3 réponses

Meilleure réponse
abdelfetah2007 2 Messages postés mercredi 10 janvier 2007Date d'inscription 27 janvier 2007 Dernière intervention - 23 janv. 2007 à 14:34
3
Merci
je pense qu'il faut activer le serveur avant d'activer le client et désactiver le client avant de désactiver le serveur.

Merci abdelfetah2007 3

Avec quelques mots c'est encore mieux Ajouter un commentaire

Codes Sources a aidé 125 internautes ce mois-ci

Commenter la réponse de abdelfetah2007
Meilleure réponse
abdelfetah2007 2 Messages postés mercredi 10 janvier 2007Date d'inscription 27 janvier 2007 Dernière intervention - 27 janv. 2007 à 15:44
3
Merci
chanj la propriété  ServerType=stNonBlocking et   ClientType=ctBlocking et sava marcher

Merci abdelfetah2007 3

Avec quelques mots c'est encore mieux Ajouter un commentaire

Codes Sources a aidé 125 internautes ce mois-ci

Commenter la réponse de abdelfetah2007
Meilleure réponse
momo2007ma 3 Messages postés samedi 13 janvier 2007Date d'inscription 26 avril 2007 Dernière intervention - 10 févr. 2007 à 12:51
3
Merci
Merci Abdelfetah,


ca marche en mettant ctBlocking


 


 


 

Merci momo2007ma 3

Avec quelques mots c'est encore mieux Ajouter un commentaire

Codes Sources a aidé 125 internautes ce mois-ci

Commenter la réponse de momo2007ma

Vous n'êtes pas encore membre ?

inscrivez-vous, c'est gratuit et ça prend moins d'une minute !

Les membres obtiennent plus de réponses que les utilisateurs anonymes.

Le fait d'être membre vous permet d'avoir un suivi détaillé de vos demandes et codes sources.

Le fait d'être membre vous permet d'avoir des options supplémentaires.