Gridview + itemtemplate

Messages postés
88
Date d'inscription
vendredi 23 juillet 2004
Statut
Membre
Dernière intervention
18 avril 2008
-
Messages postés
88
Date d'inscription
vendredi 23 juillet 2004
Statut
Membre
Dernière intervention
18 avril 2008
-
Salut à tous,

J'ai une question qui me parait assez simple, mais je n'arrive pas à trouver la solution :

Voilà, j'ai une Gridview avec plusieurs colonnes remplies par une database.
Je souhaiterais rajouter une colonne 'itemtemplate' avec un  bouton. Par contre je ne sais pas quel evenement se déclenche lorsque j'appuie sur ce bouton.

Cependant, lorsque j'appuie sur ce bouton sans avoir écrit d'evenement, il me sort une erreur :

Argument de publication ou de rappel non valide. La validation d'événement est activée via dans la configuration ou via <%@ Page EnableEventValidation="true" %> dans une page. Pour des raisons de sécurité, cette fonctionnalité vérifie si les arguments des événements de publication ou de rappel proviennent du contrôle serveur qui les a rendus à l'origine. Si les données sont valides et attendues, utilisez la méthode ClientScriptManager.RegisterForEventValidation afin d'inscrire les données de publication ou de rappel pour la validation.

Pouvez vous m'aider svp?

merci

2 réponses

Messages postés
260
Date d'inscription
vendredi 2 décembre 2005
Statut
Membre
Dernière intervention
3 novembre 2007

Salut,

Je suis pas 100% sûr d'avoir compris t'as question.

Si dans ton gridView tu click sur Edit Template (en mode graphique), tu peux edit tes différentes templates colonnes.
Tu selectionne celle avec ton bouton et tu double-clique sur celui-ci.
 
Tu verras alors quel est l'évenement de ton bouton

 ElpenS
Messages postés
88
Date d'inscription
vendredi 23 juillet 2004
Statut
Membre
Dernière intervention
18 avril 2008

En fait , j'ai trouvé quelqu'un qui a le meme probleme que moi. Dans une colonne templatefield d'une gridview, les "button" ne marchent pas tandisque les "linkbutton" fonctionnent!!!!!!

Et c'est bien l'evenement gridview_row_command qui se déclenche!!

Etrange.........