Ajout dans une base ?! pb !

minipod Messages postés 60 Date d'inscription mardi 18 juin 2002 Statut Membre Dernière intervention 8 mars 2003 - 14 oct. 2002 à 19:28
minipod Messages postés 60 Date d'inscription mardi 18 juin 2002 Statut Membre Dernière intervention 8 mars 2003 - 15 oct. 2002 à 13:06
Je cherche à ajouter un enregistrement dans une base Access à l'aide d'ADO !

Voici mon code:

With Adodc5

.Recordset.AddNew
.Recordset.Fields("nomcolp") = Text22.Text
.Recordset.Fields("prenomcolp") = Text21.Text
.Recordset.Fields("numruecolp") = Text18.Text
.Recordset.Fields("ruecolp") = Text19.Text
.Recordset.Fields("infoscolp") = Text23.Text
.Recordset.Fields("cpcolp") = Text24.Text
.Recordset.Fields("villecolp") = Text25.Text
.Recordset.Fields("teldomicilecolp") = Text26.Text
.Recordset.Fields("telmobilecolp") = Text27.Text
.Recordset.Update
.Recordset.Close

End With

Le programme bloque et me pointe la première ligne : ".Recordset.AddNew" en me disant : "Variable objet ou Bloc With non défini" !

Quelqu'un peut m'aider SVP ?
Merci.

2 réponses

devlobargo Messages postés 11 Date d'inscription mardi 10 octobre 2000 Statut Membre Dernière intervention 14 octobre 2002
14 oct. 2002 à 22:00
salut !

fait une req sql puis exec la sur ta base au lieu d'utiliser les trucs des adocs.

dev4ever. @ +
0
minipod Messages postés 60 Date d'inscription mardi 18 juin 2002 Statut Membre Dernière intervention 8 mars 2003
15 oct. 2002 à 13:06
ben oui mais moi je voudrais savoir pourquoi çà marche pas ??
0