Les accents avec loadVar

tunel
Messages postés
11
Date d'inscription
vendredi 21 février 2003
Statut
Membre
Dernière intervention
6 mai 2005
- 4 avril 2005 à 17:37
tunel
Messages postés
11
Date d'inscription
vendredi 21 février 2003
Statut
Membre
Dernière intervention
6 mai 2005
- 5 avril 2005 à 16:34
Je load des variables d'un fichier texte par un objet loadVar. L'une de
ces variables est du texte en français, mais lors de sont affichage
dans un champ texte dynamique, les accents s'affiche en □. Y a-t-il un
moyen d'afficher correctement les accents?



Merci d'avance

2 réponses

pegase31
Messages postés
6138
Date d'inscription
dimanche 21 décembre 2003
Statut
Modérateur
Dernière intervention
4 septembre 2013
11
4 avril 2005 à 22:23
Salut !

Alors, soit :
- Tu ne dois pas afficher ton texte dans une police qui contient des symboles accentués
- Ton fichier texte est mal encodé (UTF-8 au lieu de ANSI)

Vérifie ces deux choses et normalement tout devrait fonctionner correctement.

Peg'
0
tunel
Messages postés
11
Date d'inscription
vendredi 21 février 2003
Statut
Membre
Dernière intervention
6 mai 2005

5 avril 2005 à 16:34
Merci, mais ce n'est pas la solution à mon problème.



Mon champ texte est en Arial, et il affiche les accents qui ne viennent
pas de variables par loadVars, et le fichier est belle et bien en ANSI.



Je suspecte plus un problème lors du loading de la variable. J'ai fait plus de test, sans trouver la solution.



Ce que je met
dans
Le résultat quand je fait

mon fichier
texte:
texte.text = variables.nom

nom=é


nom=était □it

nom=aimé aim

nom=éééééé □□



Ce que je constate, c'est que le é suprime les 2 caratères qui le suivent.



En plus j'ai vu dans l'aide d'Actionscript, que le séparateur entre les variable est &, comment l'inclure dans une string? Peut-être la réponce est la même que pour les accents.



Merci pour tenter de m'aider à nouveau.
0